Strange Mag field problem

Hi! I have quite a few copters all with the Pixhawk 2.4.8 and I have never had this problem. Today I was putting together a new quad with a brand new flight controller and I could not get the Compass to calibrate in mission planner. It just wasn’t happening. I have built this exact same quad quite a few times it’s not interference. I could get it to work in APM planner but the offsets were over 1000. So I tried a new computer and another new flight controller and same thing. I have never once had a Compass fail to calibrate. So I took my trusty daily flyer and plugged it in to mission planner just to see how a known working copter should look with the coloured compas lines on the flight data screen and all of a sudden error compass variance check mag field… I did not change a single setting. this is a quad that flies every single day. Now I can’t get it to calibrate or fly anymore… something strange is happening. I tried a new computer, A new cord, known working flight controllers. I tried a laptop in the middle of a field… anyone have any idea what could be going on? The other models that I have not plugged in still fly no problem but it seems as soon as they make a connection with mission planner it’s all over…

Have you tried the Onboard calibration using stick gestures…?

Thank you for the reply! I am going to look into that stick gestures today. Yesterday night I ended up bypassing compass in preflight checks on two different copters and they both work flawlessly even with offsets in the thousands… copter flies perfect returns to home… I just don’t get why this all of a sudden started happening… honestly I’ve got about 20 hours into just trying to sort this one problem out… in the process I killed a few flight Controllers. (Won’t go past 33% live calibration. Apparently they don’t like it when you try to do quite a few failed compass calibrations… also I have noticed a couple flight controllers have very dim Red light between the green flashes not too sure with that means… like a symbol of bad health?

What version of the firmware are you using? Is it the same on each of the quads you have tried alibrating?

Hey Matt, 3.6.10 and yes the same. I’m not too sure what to think…

I should also mention that for some reason whenever I do a compass calibration I can only get the green bar in the mag 1 field to move. This is the same for every copter I’ve ever built. I’ve never adjusted settings i normally just use the compare parameters with another file to get all of my flight modes, rc mapping and preferences where I want to quickly then calibrate Excells, calibrate compass, calibrate ESC‘s and fly. This is the first time I’ve ever even had a hiccough… but maybe I’ve been doing it wrong all alone??

Hi everyone, it’s been a couple of rough flying weeks… I went from flying daily (for years) to no more flying… I am not able to calibrate a Pixhawk compass and any working copter that I plug into mission planner instantly has a problem with the compass. Never failed a single compass calibration before this started. Now copters that have worked perfectly

On mission planner there seems to be a glitch on the compass calibration screen see attached picture. The top green buttons are missing and the text is distorted. Also the green bar does not move across the screen for compass 2 on any of the copters although it used to. I tried on 2 separate computers same thing… I have also attached a few pictures of some of the now not flying copters. When I say not flying I mean bypass arming check so it will take off ok then “ekf primary change” and it’s attitude is off by a mile, Or uncontrollable yaw due to compass orientation changes. Never had a single problem until a few weeks ago… I’m at my end I’ve tried everything I have a dozen or more Pixhawk paperweights and I’m contemplating another platform don’t know what else to do. Anyone have any ideas???

No attachments. Post a .bin log file from one of the craft you are having problems with.