Startup sequence confusing ESC?

Hey guys. I posted this on DIYDrones earlier this week and thought I’d repost here for more visibility.

I’ve got a brand new APM2.6 running APM:Plane 2.76. I’m experiencing what I think is a booting sequence quirk or timing issue in relation to my DragonLink receiver.

Setup overview: APM is powered via power module and the BEC from my ESC (Scorpion Commander Series). DragonLink Rx is powered via APM input rails. Tx is setup normal, APM is setup to manage elevons; deflections in all modes have been tested and are normal.

So here’s what’s happening:

  1. When the DragonLink status shows signal lock BEFORE the APM sends output bootup signals, everything works perfectly. Normal responses all the way around.
  2. When the DragonLink status shows signal lock AFTER APM sends output bootup signals, it throws my ESC into programming/calibration. Servo (elevons) response is otherwise normal and not affected. It seems my ESC just doesn’t like whatever those initial signals APM puts out are…
  3. If I power up everything in the plane with my Tx off, then the ESC does NOT go into programming mode, but when I power up the Tx APM immediately outputs about 25% throttle.

What I’ve tried and figured out:

  • I can force normal startup by unplugging the throttle output until the DragonLink LEDs confirm signal. Add back the throttle line, and voila!, all is good.
  • I read about being stuck in a calibration loop. I erased and reset the board, went through setup, and I’m still having this same issue.
  • I’ve recalibrated my radio at least 20 times. I have also tried extending and shortening the throttle travel endpoints (recalibrating with each change) in the Tx with no positive results (so now they’re back to 100% in both directions; 1900 high, 1100 low).
  • My throttle channel is NOT reversed. I even tried a “double-reversing” to maybe trick the ESC into avoiding programming. No such luck (it was a stretch as a solution, I know).
    Let me know what you guys think. Thanks in advance!

[wf]general APM:Plane[/wf]

Okay. I wasn’t sure where to place it since I can’t definitively say I have a “problem” inherent in a battery, motor, or ESC. “General” seemed like a good catch-all for a problem of uncertain etiology.

Have you got a normal RC setup lying around to see if that is the problem??

I do not. I have tried another DL Rx with the same result.

I’m wondering if I should extend my throttle endpoints to something way more exaggerated. [Edit: Never mind, makes no difference.] What does APM do at start up to each output? The servos wiggle a bit, but what is going on in the throttle output?

Edit: I’ve installed a switch for now between APM and ESC as a workaround while I continue to find a better solution.

Hi whipLash,
If you try 2.77 and set ARMING_REQUIRE=1 then APM won’t pass through the input signal from your RC until you arm it. Try have a look at the new arming documentation and see if that helps.
Cheers, Tridge