Stable version for mro f7 zero

There is a bug in version 4.0.3 that all the parameters reset.
I try to find what is the last stable version for mro f7 zero that work fine.
mro f7 zero + gps mro location one.


That bug has been fixed in 4.0.4-rc4. Any reason why you are not using that version?

I tried to flash 4.0.4-rc4 but after the flashing the FC not rebooting.
When i unplug and re-plug ,the FC start to flash red led and not stop.

I tried to flash with Mission Planner and i get msg " No need to upload. already on the board."
No matter what version i come from 4.0.0 -> 4.0.4-rc4 i get the message. 4.0.1 - > 4.0.4-rc4 i get the message. and from 4.0.3.


Good day, im running the stabe version 4.0.3 on both control zero i have, with out any issue.
Did you try check the wirings on your ubs cable.?
For LocationOne the latest release is the f303-M10070 ap periph 1.1.0.
If you have Ubuntu environment you can also compile it

Hi Dave, thank you.
Strange problem,when i flash 4.0.3 after 3-4 reboot the parameters reset.
“Did you try check the wirings on your ubs cable.?” is the cable of mro supply,with pico-clasp.
Yes, i use ubuntu environment how can i update the gps?


if you want update the firmware of your gps module you need first build the binary file and flash it using MP UAVCAN option.
For build the firmware using Ubuntu under Windows environment you need follow this wiki.
For control zero just format your sd card and flash the firmware again

I will try to update the gps and format the sd card on the FC.
And i will update if have changes.

Thank you.

this is the last binary file i’ve build for mro location one…

AP_Periph mro location one.bin (107.5 KB)

1 Like