Spool Up Swash movement

Hi guys,

I know its not autopilot related but was not sure where else to ask.
I have an 800 size Petrol heli that I finally managed to build up the courage to test for the first time with my new autopilot.

Once I flick my interlock switch and the motor starts to spool it gets a third of the way up and the swash starts to do a movement that I can only explain by saying its as if I had inputted a full circle on the cyclic stick, it does about 2 revolutions like that at maximum pitch in both pitch and roll then stabilises as the throttle increases. After it finished its spool up, it sits there fine with no obvious movement.
(I had no way of videoing this action at the time)

My first thought was some mega vibration at a particular RPM, but once it spooled up, I then flicked the interlock back on and during its spool down it does not repeat this phenomenon.
It also did not do this when I had smaller 700 size blades for practice before I had fitted the autopilot.

I know its not autopilot related because it did it before with some other 800 size blades that I had to send back, I assumed at the time it was because they were not balanced properly, but this set I have had the head out to balance.

Any ideas, or have I explained it horribly?
(I have been thinking all day about how to describe it)

Thanks in advance,

@SimonOakes did you check the log just to be sure there was no commanded input? You are probably right but it is worth checking to be certain. The only other thing that comes to mind is servo strength. Are these servos strong enough for 800 size heli? I used servos from my flybared heli in a flybarless heli. They were not rated for the torque of a flybarless heli and I could tell when I was hovering it that the servos were stalling and not able to handle the load from the blades. Just a thought. Hope you can figure it out.

Hi Bill,

This is something I had not considered as when I was given the heli they were already fitted, I had assumed that it all came in a ‘kit’ as the heli is JR Propo and the three swash servos are JR DS8235.
Looking at there specs they have a 9.6Kg torque rating, is this the information I am looking for?

I do not remember the Heli’s construction manual saying about torque rating for the servos.
I only have the manual for the later GSR260Z version, but that says a full radio system is required, but I can not find anywhere in there about torque rating for this size Heli.

Reading your post, my heli is a flybar heli, as this would mean I do not need such powerful servos?

I did just re-check the log, although I am new to this, looking at the graph, I enabled the z Vibe as this shows me exactly where the ramp up occurs and I then enable the RCIn for C1, C2 and C3. These all remain at a constant output, so to me this means no input?

Those are the transmitter controls. You want to check RCout C1, C2 and C3. That is the commanded output from the auto pilot to the servo.

Okay, so I just re-checked the log. They are not a completely dead flat line, but they are definitely not showing any form of output that would create the movement I witnessed.
Looking at other 800 size heli kits, they seem to come with 20-25Kg torque servos, would it be worth getting some higher rated ones to put on?

Then we can pretty much say that it is the servo that’s the problem.

If those are the size servos they recommend for a 800 flybarred helicopter, then yes I would purchase more powerful servos.

If you plan to have telemetry on this helicopter, then you should buy a good servo because some are not as well isolated from interference from those telemetry radios.

Okay then, I shall get some different ones.
Do you or anyone else have any suggestions or particular favourites for this size heli?
I do plan on having telemetry.
I can not find anywhere anything about recommended torque ratings for particular sized helicopters, so I guess I will just have to go off other kits suggestions.

I may also for now put on my smaller 700 blades as before the autopilot it seemed to fly well enough with them. At least I can get it in the air and get some logs to study.
Has anyone else got a CUAV X7 pro that they have used, or would it be worth posting some logs on here no matter what the happens during the flight?

Are your servos digital? Saying it because i had some un-commanded movements on my heli when i accidently tried to use analog servo with arducopter.

Sorry for the late reply, yes I am confident that they are digital servos.

Do not know if you have solved thi s phenomena…
Did you check RC out ? to see if the AP has commended the servos movement ?

Sorry I missed this, I have not had the chance to play with it since with smaller blades or more powerful serbos, checking the log confirmed there was no output from the AP though.