Spektrum SRLX2 receiver not connecting

I have a Spektrum SPM4650C SRLX2 receiver I’m trying to use with my Pixhawk 1 but cannot get it working and not seeing any movement from the bars in the radio tab. I’m using the latest 4.14 copter version and have the signal wire connected to the TX pin on Telem 1. I have serial1_protocol = 23, serial1_options = 4 and rssi_type = 3 all set.

I have tried two different receivers and two different wire connectors as well as trying my orange cube and tried wiping the settings so I’m starting with default setting with no positive results. The receiver has power and I can bind it but cannot get anything into arducopter.

Any advice on things I can check?

Thanks in advance.

I think you want SERIAL1_OPTIONS=12 - at least that’s what I have set on my miniquad with one of these.

If that doesn’t work I do have a Pixhawk 1 I can try and verify on

Thank you for the reply. After closer inspection I had rx and tx pins swapped and now it works with all the previous settings set as per my initial post.