Speed Change in Auto Mode very aggressive

Is there a way to make the transition from higher speed to lower speeds less abrupt in Auto mode.
My copter changes speed on a waypoint ie from ie 8 m/s to 5 m/s with very ugly braking.

“WPNAV_ACCEL” should control how fast the copter changes speed in auto mode.

there is a fix, as far as i know it is currently in master, and will be in Copter 4.0.4

1 Like

Should, but actually it does not. https://github.com/ArduPilot/ardupilot/pull/12821

1 Like

I’m having this problem too. I have flashed copter 4.0.4 but the change speed accel havent changed, there’s no where which explains how to configure this feature (if it is configurable), if it should be an auto feature, its not working.

Is there something that I have to change to make this work?

PS: when the auto mission starts, the change speed from 5 to 10m/s for example is very smooth, only when the speed decelerate from 10 to 5 (end of mission), the stop is very abrupt.

What is your WPNAV_ACCEL parameter ?
Also, could you share mission and log ?

My wpnav_accel is 100.

I dont have any mission or log here, sorry.

PS: in the end of my missions, dont have a do_change_speed from 10 to 5, for example, my last waypoint is a return to launch and that is what makes my copter to abrupt brake. Perhaps I should not use RTL when making my mission and use land on home point?

Hello and thanks for the help received so far but I can confirm now that 4.0.4 works really well and smoothly in speed changes in Auto mode. I have tested the 4.0.4. several copters and all performed really well. I have tested Orange Cube and on Black Cube.

Set 1 sec waiting time at the last waypoint before RTL. Then your copter will stop slowly then start RTL.

Sure, I will try.