[Sovled] Servo plugged in AUXOUT no response


My servo is connected to AUXOUT, AUXOUT1 should correspond to Servo9 in MP, I set the function of servo9 to receive the signal from RC9, but when RC9 sends a command servo does not respond.

I tried this method before and successfully controlled servo by remote control and pix, but today it didn’t work, I tried three servos and tried MAINOUT 5-8, AUXOUT1-4, but finally it still didn’t work!


Note: I set whether or not to enable the safety switch to NO via the parameter BRD_SAFETY_ENABLE

Do you have power going to the servo?

I think that is the problem, but I do not know how to make it get power


You will need to supply power from an external BEC.

Sovled. Thanks .

But what still puzzles me is that I successfully drove SERVO before that and did not use BEC. I should be able to understand this problem in the future.

You probably had an ESC plugged in that provided the +5v on the servo power rail.
If you do have ESCs that provide make sure only one of them has it’s power connected to the servo rail. Terminate the power wires of the other ESCs so they dont connect to anything.