Sonar - Seem to can't get it working in flight

I hope someone can help me with this. I installed a XL-EZ4 Sonar on my APM2.6. I made the filter in the cable and mounted it on my Discovery. When I test the sonar through the Terminal option in Missionplanner, Test-Sonar, everything works fine. It shows all distances greater than 20cm.

But in flight it does not seem to do anything. Both in the Initial setup/optional hardware/sonar option and the Flightdata/status the parameters show 0 on sonarrange and sonarvoltage.

I probably do something wrong or forgot something, but I don’t know what.

Thx! :slight_smile:

I’m getting this too. The Terminal test ‘sonar’ appears to work fine, but the front-end only shows zero.

Yeah I’m seeing the same thing. When I connect to the latest version of mission planner (1.3.9) with 3.1.5 fw it doesn’t even show sonar selection choices in the combo box (I have an LV-EZ0). I too can do Test - Sonar in the console and everything seems to work fine, but any sonar distance or voltage readings in flight data show zeros. APM planner 2.0 shows the sonar choices in the combo box, but enabling it there still doesn’t seem to do anything. Let me know if you figure this out.

Yeah, post-update the dropdowns are empty. Not sure where to start looking at this point, hopefully someone wiser than I will chip in :slight_smile:

Same problem here. Did anyone find a solution?

Hi everyone;

I installed the same above sonar on my ARDUROVER, but I am not able to 'ENABLE IT’
When going to the initial setup screen and select SONAR, I can see the distance and voltage varying when I move my hand closer or further from the sonar. However, the problem is I am not able to tick the sonar box to enable it.

On the terminal, I type ‘test’, then ‘sonartest’. A warning shows up saying “Sonar not enabled” and show zero reading

When I enter setup mode, the command “sonar on” is not recognized.

Anyone encountered same issue?


Yes, you are right that the Sonar, which is now called Range Finder I believe, function cannot be enabled in the ArduRover2 firmware.
During the updating of the Rang Finder library to include additional types of sensors, the ArduRover2 Sonar function became disabled and cannot be enabled at this time.
Sorry for the inconvenience.
Our Developer/Programmer Andrew Tridgell, when he becomes available, should be able to restore the sonar functionality.

Is there any progress on running sonar on Arducoper? I have my multirotor with latests 3.1.5 Quad (mission planer 1.3.10) and even sonar test in terminal works great still sonarrange, sonarvoltage are 0 and alitide is calculated from baro instead of sonar (I enabled my sonar).

Should I sell my sensor or just wait?
Any news about sonar support in arducopter code?

3.2 stable is almost ready…and still no response, does anyone look sometimes into that forum? Why sonar doesn’t work both on 3.1 and 3.2 on arducopter for quadrocopter setups? I got correct data from MB1240 sensor but alt hold uses baro and sonarrange/sonarvoltage doesn’t show correct value?