[solved] Unable to allocate scripting memory

Hello,

I updated to 4.05 and I’m getting the message “Unable to allocate scripting memory”. The fc does meet the requirements described in the docs. Its an mRo X2.1. Previously I did not have any issues.

Has there been a change which can result in this issue?

Thx,
Tobias

The change was probably that it did not complain before, and it does now.
My guess the problem was there all along.

1 Like

THX, but I’m not sure because the scripts where previously working and stopped to do so now.

I have now tested the same script and same settings with a Pixhawk 2.8.4 and it runs without problems. It is a simple startup script which changes the flight mode. It does work on previous Arducopter releases on different X2.1 but not on my current X2.1 with AC 4.0.5 which makes me wonder if the device is defective or if there is something else going on.
Any ideas? I’m a little bit desperate because I already tried many things like adjusting the memory and deactivating SRTL and Terrain Following.

you can also save memory by disabling some EKFs. So the EKx_IMU_MASK parameter can be set to “1” to only enable one EKF. Also make sure that only EKF2 or EKF3 is running by checking/changing EK2_ENABLE and/or EK3_ENABLE.

1 Like

Thank you very much @rmackay9 and @amilcarlucas!

I must apologize, found the error - of course my fault and nothing wrong with AC or the mRo X2.1.

I uploaded the parameter set for an older AC version and that caused the error. I had a log buffer beyond the standard size.

1 Like

please i have same ur problem but it didnot solve
can u help me
i use mission planner with pixhawk 2.4.8

Update to Arducopter 4.1.3-rc2

sorry mr
is this firmware

Yes firmware. And reset all parameters