SOLVED: Pixhawk 2.1 doesn't boot with USB / no batt

This is when booting with USB power only.

FC plays the normal startup music and just continues fast blinking the red LED on top of HERE. 2 side LEDs will not light up.

It started happening after a period of 2 months with only some occasional issues. It now happens in 95% of cases. Only rarely the boot process completes fine.

Once in this state i cannot connect to it with MP, QGC or APM Planner 2. This state resembles the firmware flush mode. In fact i am able to perform firmware flush.

Powering from batteries works fine.

There is no log file generated on SD during the failed boot.

firmware version: copter 3.5.4 - i have reloaded it a few times to correct the problem.

I had a reverse problem on 3.5.3. Powering from USB only was fine. Powering from BATT would get me to the state described above and 3.5.4 corrected the problem for a while.

SOLVED (12/24/17): as recommend below powered USB hub fixes the boot issue. Also disconnecting peripherals makes it boot via laptop usb power which i would recommend for firmware flashing.

The 2.1 needs decent amount of power as it starts heating the oven inside. Chances are either you are not using the supplied USB cable (designed for higher current) or there is not enough power from the USB port. Try a powered hub.

thanks - i am using the supplied cable and drawing power from my Lenovo Think Pad T530 laptop.
Is it possible to provide power via the other 2 USBs on the other side and use the main Cube USB for data?
Otherwise i don’t really know how to make my PC supply more power to the cube. i will research USB hub option.

Ah, I have never managed to connect with a laptop. They generally can only supply 200ma which is not enough.

"Is it possible to provide power via the other 2 USBs on the other side and use the main Cube USB for data?"
No, one port it OTG for the Edison and the other is terminal for Edison.

Your best bet is to use an externally powered USB hub, the power cones from a separate plugin power supply.

Honestly, i just generally use power from a battery. This is fine as there is no power feedback to the USB.
This is only a pain when installing firmware, as you have to cycle the power to get into the boot-loader.


i found the following statement on autopilot page contradicting the USB HUB theory:

Connect flight controller to computer

Once you’ve installed the Mission Planner onto your computer, connect the autopilot board to your computer using the micro USB cable as shown below. Use a direct USB port on your computer (not a USB hub).

are you confident i can use a hub like one referenced below to manage the configuration using MP?

BTW - i also tried powering PH using phone charger thinking there is enough Amps there - did not boot.


I would not load firmware via a hub but for config it is fine.
The hub you linked looks OK.
I’m a little concerned it did not boot from a phone charger, it should have done.!!!
Saying that if it is a branded ‘smart’ charger, it may not allow much current draw as they ‘talk’ to the phone to check if it is genuine or not before supplying full power.

true, i have bunch of peripherals connected so smart charger may not be enough.

gps2 (holybro)
Lidar Lite v3