[Solved] PIDs not displaying

I’m not sure if this is a 4.1 beta issue or a Mission Planner issue but the roll and pitch PIDs are not displaying in Mission Planner. Here’s a log of a flight I did today. There’s a screenshot of Mission Planner here.

Please update your mission planner version.

I must have installed that from an old file when I was troubleshooting Mission Planner earlier on. Anyway, I’ve updated Mission Planner to 1.3.74 and the issue is still there.

Try with the beta version of Mission Planner.

I can’t locate a beta version of Mission Planner. There is not ‘Check for Beta versions’ at the bottom of the Help screen as Wiki instructs. Do you have a link?

Mine is on 1.3.78
Do you have these in the Help screen?


Maybe uninstall, reboot, download and install a fresh copy??

Also try:

  • In Config / Planner set the Layout to Advanced
  • Connect a flight controller
  • Hit Control F (temp menu) and the “Param gen” button, 7th down in the left column

I installed 1.3.74 but 1.3.71 was still starting up. I corrected that so 1.3.74 starts and the Check for Beta Upates button was there. I used it to install the beta and that fixed the issue.

It’s curious that you are running 1.3.78 as it looks to me that 1.3.74 is the newest?

Anyway, thanks for your help. The PIDs display properly now so problem solved.

Sorry, I got the 1.3.78… from the build number - Version is still


I have the same problem,but fix after installed the latest mission planner,but I found another problem.The PID of the initaiting setting is very low in firmware 4.1,the old initaiting P value is 1,but the new firmware4.1 is just 0,and after autotune,the p value was set to about 0.2 ,is that ok? or may be there is different unit of P value in the firmware4.1?