(Solved!) No. of sats going to 0 for a second during the flight?

Update: Problem solved.See post no. 24

HI all,
I would like to know the cause of my GPS glitch.I am seeing no. of sats going to 0 from 16~18 sats for a short period of time(sometimes 1/2 a second to second) during my heli flight.Sometimes it doesn’t happen at all,sometimes once or sometimes more than once.GPS is u-blox M8 and mounted on a tail boom around 4" away from my R-XSR antenna.FC board is omnibusF4ProV3.

Could it be serial communication issue with the board or something wrong in the GPS itself?

Check GPA.Delta if it goes up at the same time, it means you don’t get packet from the GPS. Most likely a wiring fault or a cheap ublox knockoff :slight_smile:

Thanks Andras

for replying.
Glitch occurred 4 times on this flight.

On 3 events, delta went up little but on 1 event it didn’t as its seen in the graph.

It looks like a faulty gps receiver.

Yes delta goes up to 3.5 milli seconds on 3 occasions.

Is there any parameter to adjust the packet speed on ardupilot if that can help?

it wont help, it must be update at 5Hz. It does but the packet does not have any sats, it means the receiver does not see any…

So why does delta goes up at the same point where no. of sats came down to 0?What’s the max delta allowed?Sorry not an expert so please educate:)


Hi Andras-Not to hijack Am’s thread here but a related question for you. On this particular flight I received many “Bad GPS Health” messages via Frsky passthrough telemetry (Alex’s script) on my radio but I don’t ever see errors in the log or any other issues while flying missions with this craft. I just assumed it’s some generic error being reported as a GPS error and have ignored it. But your comments here got me thinking. What do you make of the graph? It’s a Holybro branded M8N module.

I am not Andras but try to help too. Bad GPS health means that the update from the Gps falls below 200 msec (5 times a sec 5hz). So everytime you see delta going above 0,2 you get a bad gps health message.
From the pics i’d say you got a lot of them at the beginning of the flight untill about 1/3.

Ah right 200 msec, ,makes sense. Perhaps I should consider another module, this craft travels some distance.

Thank you!

Unqualified opinion: when the basic GPS modules have a high number of sats like in your pic, the update rate can slow causing the “Bad GPS Health” messages. I was seeing this sometimes too, and really long start up times (to 3D fix) even though there was 20+ sats.
Being in Australia, I’ve been setting GPS_GNSS_MODE to 67 to limit the constellations and we still get acceptable NSats (about 15+), the same HDOP as before and faster startup times. I havent seen a “Bad GPS Health” message for some time now - although North Korea missile tests have taken a break too :slight_smile:

That doesnt explain the original posters issue though, Andras has more likely nailed that one.

1 Like

Thanks Shawn. Yea, I’m using 67 on all my modules. I have 2 craft flying where this is prevalent. One with a branded $50 module and the other likely a cheap knock-off with a mini form factor.

What version of the firmware was involved here? A git sha would be handy.

There was a bug in the uBlox parser which could cause what you’re seeing here.

1 Like

If you are asking about my post it’s a 4.0.4-dev version from @andyp1per with the Double Notch filter. Installed it for trial several weeks ago and it’s been flying so well it’s still running.

I am running latest stable Arducopter helli version.

ArduCopter V4.0.3 (ffd08628)
ChibiOS d4fce84e
omnibusf4pro 001D0047 324D5007 20333256

On one of my flights, it happened only once in 15 mins flight.

First GPA delta went up to .303 and then fell down straight to .120

In the second pic,i zoomed it to the point where it happened.

Any 4.0.4-dev would have the parser fix in it.


1 Like

Thanks Peter.

Strange thing I noticed that no. of sats go down after my heli oscillates.My GPS is mounted on the tail boom close to the tail and away from CG.So if my heli starts oscillating(as this is my first heli build and i am in the process of tuning), my GPS looses sats.There is no communication fault as GPA delta remains good.

So would vibration cause aliasing in the Doppler measurements?Being GPS away from the CG, the movement of oscillations gets amplified.

another thing is GPS is powered from a servo rail.So during oscillating , swash plate servo are moving fast under stress.Could that cause voltage issues on the gps power?

I also noticed that blinking light on the GPS stopped blinking at that specific time.

Here is my log.

Never ever powerGPS or other sensitive electronics from servo rail. Servos feeding back massive noise to their power line. No surprise the RF frontend of your GPS goes haywire :slight_smile:

1 Like

Ahh… that explains it.Going to change the wiring.Thanks Andras.