[SOLVED] Kakute F7 not displaying Voltage Bat. 0V


I setup Kakute F7 with these parameters, but unfortunately I do not have voltage neither List of Parameters nor HUD.

  • BATT_VOLT_PIN = 13
  • BATT_CURR_PIN = 12
  • BATT_VOLT_MULT = 10.1
  • BATT_AMP_PERVLT = 17.0

Kakute is conected to TEKKO 32 4in 1 65A.

What I am missing? Thanks.

That’s what I am using on a KakuteF7Mini with a Tekko and it works fine

What a Strange… I am missing something, and I cannot arm either… Currentyl these are my 2 issues. I come from betaflight, I have 4 quads setup in betaflight, but Arducopter is totally new for me.

I followed the instructions but I do not receive Voltage values, and I am not able to arm. This is quite difficult than BT or INAV. :S

Have you used the wizard in mission planner to configure your quads?

No, I went step by step from hte beginning with the mandatory configuration, calibrate accelerometer, radio and so on…

check out my detailed “findings” post over on

Check also
serial5 protocol 16
Servo blh auto 1

Finally check
Servo blh poles to the number of poles of your motors.

I have the same configuration and it is working for V, rpm and esc temp, but I cant read current. I think it is a fault of the sensor but maybe I am also missing something.

If you can’t read current thru telemetry then the 4in1 does not have a current shunt resistor on each ESC on the board. This type typically has a shunt resistor for total current and it’s output is analog voltage on a sperate pin.

ok, I reflashed the firmware and I followed your tips, now is working. But I have another little issues:

  • with the RSSI: always shows 100%, but I remove the antenna, should drops and it does not move…
  • “PreArm: Batttery 1 lopw voltage failsafe”…

What RX do you have? If the driver supports it then typically you would set RSSI_TYPE = 3

Dragonlink MicroRX v2. Must I setup in a PPM external pin or would be possible to rout it though SBUS?

It is the tekko32. It should have.

Looks like option 2 is what you want, but I have never tried it myself

Ah ok, I go it. It is confuse, because in the OSD apperas the % but actually is not the RSSI, I had to activate the RXRSSI in the user parameters.


Now everything is solved. At least basics setup, I can arm motors, disarm, and basic telemetry. Next steps is to fly, and test different flight modes… Another story.

Thank you!