[SOLVED] 3.5.0-rc4 Looses frame type on reboot

I just got a Pixhawk Mini (=pixfalcon?) from 3DR and flashed 3.5.0-rc4 on it.

If I try to arm the unit I get the following message:
“PreArm: Motor Interlock Enabled”

It doesn’t matter if I have a CHx_OPT set to Motor interlock or not and if I have a channel set it doesn’t matter if it’s on or not.

EDIT: Found this possibly related thread: 3.5.0-RC2 On Heli with Pixracer- Can't Clear Motor Interlock (Solved)
And looks like that setting the frame type from HELI to HEX did not get saved so it expected a valid input on CH8


I can’t seem to save the frame type/class setting. I can select it in Mission Planner Initial setup or set the parameters manually but once I reboot the controller the frame is set back to a heli. What should I do?

Looks like the issue was fixed by flashing the firmware with mission planner instead of QGroundControl which I first tried to use. QGC did not ask for a frame type while mission planner did though thought the 3.5.0-release was supposed to do away with the different version for different frames

Mission Planner for the win, I like other software but I trust only MP for set up

I was originally trying PX4 with QGC but ended up flashing A:C from there and then moving to MP for the actual setup. Apparently I should have moved to MP a step earlier. (Or used a later QGC build as later said by Francisco on gitter)