Smartrtl Deactivated buffer full

I got a weird error today.
Was just sitting at the field…Had just powered up the quad when a minute or so later I got the announcement Smart RTL disabled Buffer full. What the heck. I have never run into that one before.

|19:00:55|ArduCopter V4.0.4-rc3 (d70e75b3)||—|---|
|19:00:55|ChibiOS: d4fce84e|
|19:00:55|fmuv3 001C002A 33375110 31313537|
|19:00:55|Param space used: 1656/3840|
|19:00:55|RC Protocol: SBUS|
|19:00:55|New mission|
|19:00:55|New rally|
|19:00:55|Frame: QUAD|
|19:00:55|GPS 1: detected as u-blox at 115200 baud|
|19:00:55|u-blox 1 HW: 00080000 SW: 2.01 (75331)|
|19:01:54|EKF2 IMU0 in-flight yaw alignment complete|
|19:01:54|EKF2 IMU1 in-flight yaw alignment complete|
|19:02:50|SmartRTL deactivated: buffer full|

Hi Ricky- I have seen that many times. If you want to continue to use Smart RTL on long flights increase the SRTL_ACCURACY value from default (2m) so the buffer doesn’t fill.

1 Like

thanks Dave
just found it odd to get that 1 minute after boot up

SRTL only had 7 points (from somewhere…) when the maximum was set to 300. You’ve got GPS settings but nothing is logged for it, there’s Lat and Lng readings in the log though.

DSF.Bytes takes a nose-dive, maybe that’s indicative of running out of memory for some other reason.

Hey Shawn.
Ya it’s really odd. I rebooted the craft and the error went away. I had no further error of that nature. I will keep an eye on it and report if it happens again. Very odd.
The problem I am up against now is I keep getting the message Trim Saved…huh. Why.
Will check my config in case I set something wrong.

got it again
SmartRTL deactivated: buffer full