Slow yaw without stick input

I recently tried to put a notch filter on a quad I had built over 1 1/2 years ago…it is running latest firmware the last time I flew it all seemed good… after the hover flight I changed the values for the notch and sent it back up only to see the copter slowly yaw to the right with no stick input… I checked the values on the taranis and made sure the trim and min max values were hitting the pwm values in mission planner (adjusting the taranis while watching mission planner radio tab values) no noticable issues though I tweeked the trims…but it still yawed to right… next I verified all motors were true and then removed the notch filter in case it was a result of some change… however it still yaws to right… attached is a log I am not sure what to try next…any help is appreciated
Todays log -!AmW8JONezY1UgpdAd-eLj8fW8eNO0w?e=QxFDcZ


Compass 2 is getting affected by throttle, and Compass 1 is not

So just probably check the Compass ordering and disable the onboard compass, that might fix it.

If you want to use the Harmonic Notch filter and run another Autotune, use these settings derived from your log data:
INS_HNTCH_ENABLE,1 <- set this then refresh params to see the rest

wow, I would love to know how you knew to look at the compass and even more so how you were able to graph using what looks like the sqrt of the x,y,z ?

after disabling the onboard compass is there any need to re-calibrate?.. I will try to fly later if the weather cooperates… I will also add the notch as thanks to your help it has made a huge difference on my other copters.


Lots of analysis tools available with the pull down menu. That’s one of the more useful ones.

The notch looks good, thanks for looking at this, however the copter still wants to yaw to the right though It seemed a little better … - new log attached below It seemed a little better …!AmW8JONezY1UgpdBNwvYFjQkFdM82A?e=YrLTjf
seems weird that it started doing this after over a year of use (though it hadnt been flown in 1-2 months prior to this past week… if you need to see the wiring / build the pic (2) show the esc PDB wiring and the wiring going into the cube!AmW8JONezY1UgpdFRPMEt4UhedjSjQ?e=AKpq3c


There’s a couple of things I would try next

RC Calibration
RC4 (yaw) trim is 1461 but actual RC input during flight shows exactly 1500 PWM - this is probably the real issue

  • Clear all transmitter trims
  • Run the RC Calibration and see if those two values align, or just set RC4_TRIM to 1500
  • Try setting RC4_DZ to >20 if there’s still an issue

Compass Calibration
It actually seems OK, but if you feel like calibrating…

  • no need to change any compass settings from present values
  • go outside and wait for a good stable GPS 3D fix, run the compass calibration

Yeah I’m pretty certain it’s the RC Calibration / Trim setting now.
You can see in this graph that RC4 momentarily comes down to near 1460 while you are making yaw corrections, and the Desired Yaw heading flatlines

It would have been more apparent if you’d tried to hold the yaw steady for a few seconds, but I think you can easily fix it now.

Thanks shawn…I changed it…thought I checked the trims but I missed it …I think you may have saved me from tearing it down and going over all the wiring again

Check the ranges also. I’ve had one channel be off after calibration for some unknown reason and it caused problems