Skywalker crashed during auto takeoff

usually I’m with copter but wanted to give the planes a try… Well, total disaster, total loss.

Finished my Skywalker 1800 build a few days back and got into tuning. Worked out pretty well and calibrated the Airspeed Sensor and flew some time without auto tuning. Got some autotune recently and was quite happy with the results.
Today i wanted to try auto takeoff and auto landing feature. The first times it worked out great. Just great.
The last flight before the crash i got a successfull auto takeoff with some waypoints and a nice auto landing. Just changed a few waypoint settings and wanted to takeoff again. This time I had my RC not in reach because the times before it was even not necessary. Well… throw the plane and it just got in a slight left bank angle with full throttle. But no altitude. Flew in this angle until it impacted the ground at high speed. Was a sudden and total loss of the airplane.
As i said i’m more into copter and so i don’t have any experience in analysing plane logs; i hope someone can help me figure out what went wrong and maybe i can avoid this shit if i decide to build a new plane.
Attached is the log file. There are some flights with auto takeoff and landing in there but the last one is, obviously the questionable one

I’m afraid that your last takeoff was not an automatic takeoff. It was an attempt to head to another waypoint, and that was not what you really wanted.

Here is your second-to-last flight. It had a takeoff command and takeoff triggered message with it.


Here’s your last attempt the resulted in a crash. #1 is that I found no takeoff message. #2 is that I see the demanded bank is far too high for a takeoff. The aircraft fails to have pitch authority because of the severe bank angle, and its airspeed also increases far too much because of the lack of pitch authority and resultant reluctance to climb.


Ardupilot does not automatically reset the mission upon reloading a new mission. You would need to set MIS_RESTART = 1 or click restart mission before attempting another takeoff.


I’m sorry for your loss :frowning: I’ve suffered failed takeoffs too for other reasons, usually being user error. One of my takeoff checks now is to look at the elevator and see if it is neutral when I hold the plane at my takeoff pitch angle. Only then will I release.

Thank you so much Nathan. That is way better than what i figured out so far.

So it is not restarting with a new mission?! That is something new to me. I think i have to check the parameters on my copters because they reset the mission upon getting a new one. If there is a different behaviour in plane firmware… wasn’t aware

Thanks again.

The defaults may be different between copter and plane, but I’m not positive. I’m pretty confident in the reason that it banked so much and wasn’t able to climb though. Do you have a t-log from telemetry?

Here is the Tlog:

You can see the automatic landing right before, me getting the plane and shortly after that the crash.
And now i can see my mistake… Plane was stuck in the landing sequence and i was not paying attention. So it looks like there is a different behaviour with plane and copter in order receiving a new flight plan

That’s a dead giveaway. It’s also why I don’t use acceleration to trigger takeoff; I just expect full throttle when I go into auto mode. If there’s no throttle upon auto mode entry, I know that the takeoff mission item isn’t first.