Skyviper v2450gps controller doesnt launch

Skyviper v2452gps has flown before but after tinkering with Mission Planner and QFlight the controller doesn’t launch the quad. I did the diagnostics and the motors, controls,buttons work.

Probably needs a calibration or three. What messages do you see when connecting with Mission Planner when you try to arm?

1 Like

I think it wasn’t working because the drone battery was too low. I changed the controller batts and the drone battery and now it works.

1 Like

When using Mission Planner, the controller isn’t used right?

You still need the controller to be paired. Otherwise, you’ll get a FS_THR_LOW which will cause it to not ARM because it detects you have no controller.

There was a thread in the past that talked about using it with no controller. But I cannot seem to find it. Technically you can set Parameters just right to get it to function fully autonomously. But I think it is typically frowned upon because most regulations require you to be able to take control if needed.

I can’t seem to get any traction in pairing the 2450gps with tower, mission Planner, or qground control.

i assumed you followed all this?

1 Like

Got it. Had to change to MAV1. Now to fly a mission. Thanx

Used Mission Planner on my Kindle to create a simple mission and lo and behold it worked. I then added another way point and worked great.
I am so excited now!

1 Like

nice! congrats and have fun!