Skyviper Journey 2450 Gps

Skyviper Journey 2450
I tried installing arducopter firmware on my new skyviper drone and its now basically a paper weight. When I plug the battery into the drone it comes on and the led’s blink rapidly as if it was waiting on the transmitter to bind. after about 8 seconds all Led’s stop flashing and the drone looks as if it is off. I cant figure this out for the life of me. I reinstalled arucopter on my sd card and still no change. i would appreciate if someone would be able to help me out. Thank You Very much in advance.

These are the files that I put on SD card. Since the upload the drone has been doing as described above.


Update the firmware thru the webserver. I don’t know that by just placing the firmware on the SD card it will do that. At least that’s what I do.

EDIT: I stand corrected. You can do as you suggest by renaming the firmware file to “flight_fw.abin”. I don’t know how to update the Sonix board in this fashion.

When you say web browser are you referring to the IP address?

Yes. That’s how I typically update firmware but the method you used should work for the FC. Just don’’t know about the Sonix board and I don’t use the stock Tx.

I can’t even find the remote to the drone because it only comes on for like 8 seconds or so. It doesn’t even put out the wifi like it used to. Like I said the lights blink rapidly on the drone for about 8 seconds and then it appears to turn off. I can still see a faint tiny blue led that is on the FC board thru the pastic that covers it.

Do you mean the remote won’t bind to the SV? Have you checked the integrity of the battery? Have you tried to follow the steps to factory reset the drone?

The blue light you see is from the GPS board.

You may have to take apart the drone and check the wires and solder joints to make sure there are no loose connections.

@cbert Yes that is what he is referring to

Also I will be attaching a link for the firmware up.
Just follow the instructions.

@cbert if you’re not seeing the wifi connection then there is a chance that either your Sonix firmware is the problem or your battery isn’t charged enough. The Sonix does really weird things if the battery is not strong enough to power it. Is it an old battery? Even if charged, it may not be putting out adequate voltage for the Sonix to power up.
If the Sonix IS powering up, and you are getting a wifi Access Point from it, then follow the usual instructions for updating the Flight Controller.
If you’re NOT getting the Wifi Access Point, it is probably the battery…the general thought from the skyviper folks is the Sonix is (almost) un-brickable. And since the entire drone’s firmware is loaded through the Sonix interface, that is a good thing.

All instructions for loading the firmware are located here:
The instructions for the 2450 and the Journey (2700) are the same…just make sure you use the correct version of firmware. Also, be sure to name the files correctly as specified within the html. if you’re trying to force load the Flight controller, you have to rename the file to flight_fw.abin as @dkemxr said.

Awesome thank you so much guys for the help I couldn’t have got this far without y’all truly. 1 more thing. Well I finally got the so to where the lights flash like normal and I also have my Wi-Fi access point to where I can log in to the web interface. The only problem I have now is that I cannot get the remote to bind. At all. The so just blows rapidly waiting to pair with the tx and the transmitter will eventually turn off because it’s not pairing with the quad. Can you guys help me out with this one also. I know I must be aggravating as hell but I’m just trying to get this thing airborne again for my son.

You can do a forced bind following these instructions:

I tried this several times. I’m gonna upload a video andshow you what it’s doing. It’s driving me nuts because I known is something very simple keeping me on the ground. Thanks for the help buddy

Hi Chad,

Send me a direct message through the system here, as there might be a few more things to try. If we figure it out, we can post the final fix/solution at the end of this thread.

We’ll get you in the air, even if I send you out a system I piece together from my desk!