Servers by jDrones

SkyViper discussion


(Filly B) #24

Try out mission planner. http://ardupilot.org/planner/docs/common-install-mission-planner.html

It can take the logs and analyze them. I still have yet to make sense of all of the options in the “review a log” section, but the “log analysis” breaks down some important parts of the log.

http://ardupilot.org/copter/docs/common-downloading-and-analyzing-data-logs-in-mission-planner.html


(doug neel) #25

Hello,
Happy New Year!! I am new to Ardupilot and i just bought my first drone. SkyViper 2400GPS. I love this drone have had great fun so far. However I am not having any luck with installing “mission planner” on my PC. I have a Dell Latitude E5440 laptop. Intel core i3. I have followed the instructions but keep getting a lot of warnings that pop up. Like “must install NET framework 4.0 or better” which is on my laptop already.
Can someone help in this matter?
Thank you,
Huntit


( .) #26

Ignore the first warning from the App. That warning is completely false. I got the same low battery warning on the v2450HD (which is not Ardupilot). It’s an app issue I think. When the battery is truly critical the quad will switch to RTL (or land if Indoor) automatically. I think it is settings issues or an app issue, since, like i said, I had the same issue with my v2450HD.


(JEFFGORDON) #27

I realize this is an old post but I’m new here and just noticed that on my stock v2450GPS the factory setting for:
BATT_CAPACITY = 3300mAh and so is
BATT2_CAPACITY = 3300mAh
I have changed both of these values to 1200mAh to reflect the rating of the stock battery as shipped with the v2450GPS.
Could this be the reason that my battery charge indicator showed a low value rather quickly into a flight? Haven’t flown yet with the new parameters.


( .) #28

probably not. the app doesn’t base anything off mah. only current voltage. If it knows the battery is a 4.44v battery, and that cutoff is at 3.33, then it calcs % off that.

either way, the RTL is set by the paramater FS_BATT_VOLT


(JEFFGORDON) #29

So, if BAT_CAPACITY is irrelevant why have a value field?

From: .


( .) #30

Well it isn’t irrelevant for some frames and some purposes. Remember AP is modular and flexible. Those values are probably just the defaults coded in.


(T McRae) #31

Never saw this one at Costco. Got the Toys-R-Us packaging that did not include the microSD card. Guess it depends on where you buy it.


(JEFFGORDON) #32

Costco informed me that their V2450GPS was seasonal @ ~ $140
The basic Target version (no headset, Tx batteries, no extra 3.7V battery, or SD card) @ ~$72 was the best I’ve seen so far (complete with 3 month warranty)


(Ronello Ninettu) #33

Hello! I’m having trouble with building the firmware for Skyviper 2450

So, I simply followed the instructions in this site (http://ardupilot.org/dev/docs/skyviper.html), however I cant seem to build it.

I cloned the codes first using (Ubuntu)

git clone https://github.com/SkyRocketToys/ardupilot

Then

cd ardupilot
git checkout skyviper-latest
git submodule update --init --recursive
./waf configure --board=px4-v3 (i also tried --board=skyviper-v2450, but it didnt work either)

However in this next step:

./waf build --target=bin/arducopter

I keep getting an error that said:

Build failed

Traceback (most recent call last):

File “/home/uavdlsu/ardupilot/modules/waf/waflib/Runner.py”, line 270, in task_status

return tsk.runnable_status()
File “Tools/ardupilotwaf/git_submodule.py”, line 90, in runnable_status
if not self.is_fast_forward(path):
File “Tools/ardupilotwaf/git_submodule.py”, line 68, in is_fast_forward
out = bld.cmd_and_log(cmd, quiet=Context.BOTH, cwd=cwd)
File “/home/uavdlsu/ardupilot/modules/waf/waflib/Context.py”, line 453, in cmd_and_log
raise e
WafError: Command (’/usr/bin/git’, ‘merge-base’, ‘1472b16c36e37312b722fbe4540e48b39abfa23a’, ‘574dfe9e2d947e3d5d7acd50033b56798a14fc1f’) returned 128

Any help would be appreciated. Thanks!


(Satoru Sasaki) #34

I read similar issue here.
https://discuss.ardupilot.org/t/cant-build-skyviper-stable-unreachable-commit-in-submodule/23177/2

Instead, now Sky Viper is in master, and we can build with like other boards. I am so impressed I can build on vagrant SITL environment hassle free,

Satoru


(Michael Walker) #35

Safe, Tested Changes to Ardupilot for SV 2450GPS

I’m a retired system programmer but a newbie to rc quads. Got a small SV quad for Christmas and I haven’t looked back. The 2450GPS is the third quad I’ve gotten and I love it. Been learning and flying the 2450 for only 4 months.

The SV web server is so cool but way to easy to fu. I’ve learned a few dos and donts and wanted to pass it on to help newbies, especially kids and non-programmers.

Under Actions on the SV web server, TMode_Action 1 thru 6 below are my personal favs but you can set them to whatever flight mode you want, except TMODE_ACTION3. It defaults to disarm and I recommend leaving it as is, although you can set any transmitter button sequence to disarm. The power button is the easiest and most logical. Turning off the motors quickly when you crash is very important. As long as you leave it set to disarm, it will always work whether you’re flying or not. TMODE_MODE1 is the initial flight mode when you first takeoff. It defaults to Loiter, I just like PosHold better. Don’t change this to an expert mode like Acro or Sport. I recommend AltHold or PosHold. Don’t get confused about Indoor mode on the transmitter because indoor mode doesn’t really exist per se. Indoor is really Loiter without GPS.

Under Tuning in the web server, PILOT_ACCEL_Z is the vertical speed. It defaults to 400 but I increased it to 500. This is your choice, just keep it reasonable, probably best to stay between 200 and 700. Haven’t yet found the actual rate in cm/sec. RC_FEEL_RP defaults to 50 but could be 1 - 100. The higher the value, the quicker the quad will respond, particularly roll and pitch. The lower the value the smoother the quad will respond.

Under Radio in the web server, BRD_RADIO_TXMAX defaults to 4. The value can be 1 - 8. This is transmitter signal strength. I noticed when my quad was over 100 feet away, there was a half second delay when performing roll and pitch. Increasing it to 7 resolved this problem. See below:

SKY VIPER WEB SERVER

Flight Parameters

Action

TMODE_ACTION1  ModeSport
TMODE_ACTION2  None
TMODE_ACTION3  Disarm
TMODE_ACTION4  ModeCircle
TMODE_ACTION5  ModeStabilize
TMODE_ACTION6  ModeAcro

TMODE_MODE1     PosHold

Tuning

PILOT_ACCEL_Z     500
RC_FEEL_RP              35

Radio

BRD_RADIO_TXMAX  7

More parameters will be discussed in the days to come.


( .) #36

Keep it up Michael. I love these. Honestly, I think the APWeb is one of the best features of the SV that @tridge added. It makes it easy to “tinker” with it in real-time, rather than having to have a laptop with Mission Planner.

I have played with a bunch of things but have shyed away from some of the tuning parameters, afraid to kill it :wink:

But I may play with those…and wondering if the BRD_RADIO_TXMAX somehow I accidently messed with that and it is the reason I am having so many issues with my radio dropping out.

BTW, just for fun, my ACTION setup is

Mode+LeftTrigger = PosHold
RightTrigger = Flip (which fails 90% of the time, need to see about making it flip MUCH faster)
ACTION1=Loiter
ACTION2=AltHold
Mode+RightTrigger=Sport (this is the mode I’m in most the time)
Mode+Power=ThrowMode

And I user Tower to play with Auto Missions (although sadly the video doesn’t work in Tower)

Also, I’m running AC-3.6 ReleaseCandidate2 on my SV, so the Skyviper app doesn’t work anymore, but that’ ok, it barely worked when i used it.


(Michael Walker) #37

Hey lordneeko, glad you liked it. I hope it helps. Sport mode is my favorite too. But, when you say ‘radio drops out’, what do you mean exactly. The transmitter stops controlling the quad? Two things come to mind. Have you replaced the batteries and reloaded the the tx firmware.

You mentioned that you use Tower. I use QGroundcontrol, which works pretty good. No video either. But when I re-calibrated my tx in QGC, the quad wouldn’t take off anymore. I had to reload the firmware and I did a factory reset. That fixed it but I was down for a week researching.

Have you noticed any difference using AC-3.6 ReleaseCandidate2. I don’t want to lose the SV video app but would consider it if 3.6 is that much better. If I did, I might need a little help. I really like it that the SV app shows me exactly what flight mode I’m in.


( .) #38

The only app which will show SV video (AFAIK) is Solex ($20! ouch!).

But for “performance” Tower can’t be beat (IMO). I didn’t like the QGC interface, but probably because it was the second one i tried.

My Tx drops out (especially) at certain angles, but I swear it used to be better. So that’s why i think it is setup. I even modded my antennas. Moved the quad’s antenna exterior (away from motors) and put a larger antenna on my Tx, and still have issues…but not AS bad. I need to check the parameter though.

You get the “newest” features when running master, but not everything is great. For example, some parameters and naming changed so the APWeb doesn’t line up with those new parameters. So you have to change them in Mission Planner instead (at least I did, when I did it in APWeb it didn’t stick). There are new features like SmartRTL, which are neat, but I’ve yet to really dive into.

Other than wanting to play with the “latest” there is no real good reason to update…IMO.


( .) #39

I didn’t find RC_FEEL_RP. Where did you find that?


( .) #40

You solved all my problems! There is another BRD_RADIO_OUTPUT (or something) parameter that looks just like this one. I had that one changed to 8 trying to get more range, but this one was still at a 4.

I changed it to a 8, and then I got over 200ft in altitude and about 1000ft slant range! Could have gone farther but it was night and i couldn’t see it anymore. nice! I wasn’t getting more than 200 ft slant range before.

Thank you!

Also, I mentioned Solex but for some reason the current Solex version freezes up when i’m connected to my SkyViper

@kellyschrock? I haven’t noticed it freezing with my Solo


(kellyschrock) #41

Hmmm, I haven’t noticed it freezing with the SV either. What’s freezing on you? The video stream? The entire app?


( .) #42

Both. The video will be frozen and I have to force kill Solex and dronekit,
then relaunch to get it back. I did update to the RC2 beta. Not sure if
that is related?


(Joe Dennis) #43

LordNeeko the other radio parameter is BRD_RADIO_TXPOW set to 8 it is the telemetry transmission power level . As for Solex freezing I was having issues with Tower crashing on my android that was caused by having udp ping enabled for some reason must have clicked that box by mistake. Could some thing similar be your issue maybe , just a gusse as I’m totally clueless about this stuff , but I am learning a bit maybe.