Skyviper Behaves differently when controller is on/off

I’m connected to the skyviper over serial, forgoing the sonix board that was included. I want to be able to control the skyviper purely by mavlink, however, I notice that if I’m in stabilize mode and arm the throttle, the motors spin much slower than when I do the same thing but the included radio controller is on. Is there any way to disable this feature? I looked at the rc failsafe parameter, but that looks to already be configured as off. Any suggestions?