Servers by jDrones

Skid Rover did not response in auto mode

Hi

I setup my Skid Rover and all is working in manual mode, also in motor test configuration.

But when I Armed and put it in auto mode, the rover did not move it. But if I move the throttle stick up from my radio, the rover does the program, is really strange, no?

Thank’s for your help

Eduard

Hi, I have exactly the same problem with a boat, it works in semi automatic mode, the steering is automatic, but the speed is partially controlled with the stick.

i take a long time just to realize this problem. I am using version 3.5.2

@ecabanas,

I think the issue is that WP_SPEED is set to zero. In rover 4.0.0 we no longer fall back to the CRUISE_SPEED if WP_SPEED is zero.

There’s also a pre-arm check that will warn the user if WP_SPEED is too low but I think it’s been disabled through the arming checks. ARMING_CHECK = 4224 which is only checking the board voltage and GPS configuration.

@canterobb,

If you have a log we can have a look but in any case it sounds a bit like you’re referring to “speed nudging” which is described here on the wiki.

There’s no way to disable nudging but we could add a parameter to allow that if you’d like.

1 Like

Hi, thanks for the reply, but this is not the case, the rover easily reaches a speed of 11 m / s. the cruise speed and the Wp speed is at 6.5m / s, in addition when the stick is at 20% it reaches an average speed of 4 m / s when the stick is at 40% or 50% it reaches the cruising speed and when the stick It is 70% sailing at a speed of 9 m / s, it is really rare, although I’m glad to know that I am not the only one with the problem. I am also using version 3.5.2, today I plan to return to version 3.5.0 to see what happens.

I was reading about the auto_kickstart and speed nudging function and I think something has to do with these functions, indeed now that I analyze this when the rover is stopped, it needs the stick to be over 70% to start the mission and then start the mission, so the stick is at 0% does not stop, but if it reaches the next wp and the stick is at 0% if it stops

Hi, now I’m more confused, use firmware 3.5.0 but the problem continues, I’m pretty confused because I’m sure it didn’t happen before.

the only thing that is different now and I don’t know if it can affect, is that I don’t have any rc receiver connected, I control everything through a lte link

thanks

@canterobb,

I wonder if perhaps the RC3_TRIM parameter has been set incorrectly. It is set to 1313 but should probably be 1500 or maybe 1530. This can happen if the stick isn’t put in the middle during the RC calibration.

Looking a bit at the logs, it appears the vehicle is often driving at the specified 6.5m/s but is sometimes driving faster than this but it looks like this is when the throttle is held higher than 50%. This is the expected behaviour of throttle nudge I think.

The image below shows the desired speed (in red) and the actual speed (in green) with the scale on the left. The blue line is the throttle input expressed as a percentage from 0 to 100 (scale is on the right).

Thank you for the quick response, it is a relief for me, because this topic keeps me very restless.

the value of rc3_trim is fine, since I use a servo that moves the throttle of a gasoline engine. I don’t use esc,

As can be seen in the graph, the boat sails much of the time at the desired speed of 6.5m / s, and follows the desired route.

the only problem is that the throttle suddenly goes to 0, now I see in the graph that the desired speed is also going to 0, this is the real problem.

Why is the desired speed going to 0? If the mission is not over.

when I use the left stick it is like a kick that reacts the boat so that the desired speed 6.5 ms or more in case the left stick is over 50%

because the desired speed falls to 0?

Why does the throttle min fall to 0 if I have set it to be a minimum of 10% in a mission?

thanks

after much reading, I think this has to do

I hope to try tomorrow.

thanks

@canterobb,

OK, you’re using a gas engine, that’s important information! We don’t have rover specific info on integrating a gas engine. The best we have is this which is more specific to Planes.

I guess this vehicle can’t go in reverse so these two settings you’ve done are good:

  • setting ATC_BRAKE = 0 is correct.
  • the output trim has also been set very low, SERVO3_TRIM = 1120 which is also the best we can do until we properly support rovers that can’t reverse.

Although you’re not using an RC transmitter, it looks like there are RC inputs coming in so I think you’re maybe using a joystick? Joystick input is handled almost exactly like an RC transmitter so there’s not much difference from a setup point of view.

Servo inputs and outputs are separate though so I don’t think having the input’s RC3_TRIM set low is useful. This will affect what is considered zero from the joystick’s throttle channel.

Could I ask that you upgrade the vehicle to 4.0.0? It’s much easier for me to provide support to later versions.

Hi, thanks again for the reply, I have no problem updating to version 4.0 as soon as I can. although I am almost sure that the problem will be solved when you connect the RC receiver

1 Like
Servers by jDrones