Servers by jDrones

SITL failure - Ubuntu 14.04

Hello, I 'm following the instructions on:

http://dev.ardupilot.com/wiki/simulation-2/sitl-simulator-software-in-the-loop/setting-up-sitl-on-linux/

to setup SITL on ubuntu 14.04 (64 bit).

Everything seems to work fine, until I get to section “Start SITL simulator”, which asks to change dir to the vehicle of choice (in my case ArduPlane) and then issue “sim_vehicle.sh -w”

The sim_vehicle command then goes and builds all sorts of things in various directories, seemingly without any problems.

At the end of the build, I get the following:

make[1]: Leaving directory `/home/andreas/ardupilot/AntennaTracker' ~/ardupilot/ArduPlane Starting up at CMAC : -35.363261,149.165230,584,353 Starting ardupilot : /home/andreas/ardupilot/.elf -S -I0 --home -35.363261,149.165230,584,353 -w --model --speedup=1 WARNING: You should uninstall ModemManager as it conflicts with APM and Pixhawk Connect tcp:127.0.0.1:5760 source_system=255 (error(111, 'Connection refused'), 'sleeping') (error(111, 'Connection refused'), 'sleeping') Failed to connect to tcp:127.0.0.1:5760 : [Errno 111] Connection refused

The obvious question here is, what manner of beast is a ModemManager? How dare it conflict with APM and Pixhawk (and if it does, why is it in there by default anyway?) and how do I slay it? You should uninstall ModemManager as it conflicts with APM and Pixhawk is a pretty obscure message, I can’t seem to find any info on how I 'm supposed to do that or if I 'm supposed to. Is the connection error that follows related?

Ignoring all this and trying to start the sim as advised via “sim_vehicle.sh --console --map --aircraft test” also fails:

sim_vehicle.sh --console --map --aircraft test /home/andreas/ardupilot/Tools/autotest/sim_vehicle.sh: line 194: realpath: command not found basename: missing operand Try 'basename --help' for more information. ~/ardupilot ~/ardupilot/ArduPlane Building sitl make -C ArduPlane sitl make[1]: Entering directory `/home/andreas/ardupilot/ArduPlane' // BUILDROOT=/tmp/ArduPlane.build HAL_BOARD=HAL_BOARD_SITL HAL_BOARD_SUBTYPE=HAL_BOARD_SUBTYPE_NONE TOOLCHAIN=NATIVE EXTRAFLAGS=-DGIT_VERSION="2e5d5176" make[1]: Leaving directory `/home/andreas/ardupilot/ArduPlane' make -C ArduCopter sitl make[1]: Entering directory `/home/andreas/ardupilot/ArduCopter' // BUILDROOT=/tmp/ArduCopter.build HAL_BOARD=HAL_BOARD_SITL HAL_BOARD_SUBTYPE=HAL_BOARD_SUBTYPE_NONE TOOLCHAIN=NATIVE EXTRAFLAGS=-DGIT_VERSION="2e5d5176" make[1]: Leaving directory `/home/andreas/ardupilot/ArduCopter' make -C APMrover2 sitl make[1]: Entering directory `/home/andreas/ardupilot/APMrover2' // BUILDROOT=/tmp/APMrover2.build HAL_BOARD=HAL_BOARD_SITL HAL_BOARD_SUBTYPE=HAL_BOARD_SUBTYPE_NONE TOOLCHAIN=NATIVE EXTRAFLAGS=-DGIT_VERSION="2e5d5176" make[1]: Leaving directory `/home/andreas/ardupilot/APMrover2' make -C AntennaTracker sitl make[1]: Entering directory `/home/andreas/ardupilot/AntennaTracker' // BUILDROOT=/tmp/AntennaTracker.build HAL_BOARD=HAL_BOARD_SITL HAL_BOARD_SUBTYPE=HAL_BOARD_SUBTYPE_NONE TOOLCHAIN=NATIVE EXTRAFLAGS=-DGIT_VERSION="2e5d5176" make[1]: Leaving directory `/home/andreas/ardupilot/AntennaTracker' ~/ardupilot/ArduPlane Starting up at CMAC : -35.363261,149.165230,584,353 Starting ardupilot : /home/andreas/ardupilot/.elf -S -I0 --home -35.363261,149.165230,584,353 --model --speedup=1 WARNING: You should uninstall ModemManager as it conflicts with APM and Pixhawk Connect tcp:127.0.0.1:5760 source_system=255 (error(111, 'Connection refused'), 'sleeping') (error(111, 'Connection refused'), 'sleeping') Failed to connect to tcp:127.0.0.1:5760 : [Errno 111] Connection refused

What is a realpath? What is a basename? Why are they missing and what should I do about it?

I 'm at a loss, can anyone help?

Hi,
I had a different issue, but I couldn’t figure out how to add a new post, so I replied to this one. This will not solve the problem of the original post.

I tried to follow the directions for installing SITL on a VMware machine with a Windows host and a Linux guest.
dev.ardupilot.com/wiki/simulatio … n-windows/

It’s a great start, but I’d like to suggest some changes.

  1. Move the link to dev.ardupilot.com/wiki/setting-up-sitl-on-linux to the first part of step 1.
  2. Merge steps 2 and 4 into dev.ardupilot.com/wiki/setting-up-sitl-on-linux
  3. In dev.ardupilot.com/wiki/setting-up-sitl-on-linux add to the Download ardupilot the make command
  4. Move the package installs under the JSBSim (Plane only) to the top of the page
  5. Move the Install some required packages to the top of the page, and add ccache to the RPM based system
  6. That’s as far as I got… I’m not clear on which directories I should be in when invoking the commands.

I have solved this by installing realpath: sudo aptitude install realpath

I suggest the wiki needs a revision. In addition to the suggestions of cynt6007 above, I would add realpath among the required dependencies at the very top (together with git and make).

@ armadillo

How did you resolve this issue ?, as I have now the same. Before it was working now not more ??

It’s been a while and also I 'm now on ubuntu 16.04. Like I said, what I did back then was to install realpath. However, I have now setup SITL in Windows 10 and 7 (on a virtualbox VM). I have not tried on ubuntu 16.04. On windows, cygwin is a bit of a pain but it more or less works so I 'm happy enough for the time being. It’s kind of silly to have to run cygwin on windows in order to make things originally written for linux work but hey, there’s worse I guess.

I’m also running 16.04 natively here. I installed realpath, but the issue remains.
I removed modemmanager, but still the issue remains.
I checked also the ports in use but I don’t see an issue. See below the listing:

Connect tcp:127.0.0.1:5760 source_system=255
(error(111, ‘Connection refused’), ‘sleeping’)
(error(111, ‘Connection refused’), ‘sleeping’)
Failed to connect to tcp:127.0.0.1:5760 : [Errno 111] Connection refused
SIM_VEHICLE: MAVProxy exitted
SIM_VEHICLE: Killing tasks
maarten@maarten-PC:~/ardupilot/ArduPlane$ netstat -lntu
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State
tcp 0 0 0.0.0.0:17500 0.0.0.0:* LISTEN
tcp 0 0 127.0.0.1:17600 0.0.0.0:* LISTEN
tcp 0 0 127.0.0.1:17603 0.0.0.0:* LISTEN
tcp 0 0 127.0.1.1:53 0.0.0.0:* LISTEN
tcp 0 0 127.0.0.1:631 0.0.0.0:* LISTEN
tcp6 0 0 :::17500 :::* LISTEN
tcp6 0 0 ::1:631 :::* LISTEN
udp 0 0 0.0.0.0:43005 0.0.0.0:*
udp 0 0 127.0.1.1:53 0.0.0.0:*
udp 0 0 0.0.0.0:68 0.0.0.0:*
udp 0 0 0.0.0.0:17500 0.0.0.0:*
udp 0 0 0.0.0.0:631 0.0.0.0:*
udp 0 0 0.0.0.0:5353 0.0.0.0:*
udp6 0 0 :::42658 :::*
udp6 0 0 :::5353 :::*

I found a “workaround” re-installing ardupilot

I have the same problem and both realpath/reinstall cannot solve the issue.
I’m using Arduplane downloaded by dronekit-sitl package.

Can you provide more details? I have the same issue.

Servers by jDrones