Servers by jDrones

Single Copter with Gasoline engine settings

Hi Andrew,
I’m really excited about your success. Do you have any photos? I’d like to see it… Do you have more details on how you got a single copter working? I can’t seem to get any of the outputs working. I have changed the FRAME_CLASS to 8 but I don’t get any servo outputs, only motor seem to register as functional. Any help would be appreciated, and better would be a complete list of all the settings.

Best,
David

Hello David,

I’m traveling right now with no access to data. I’ll be happy to assist you once I’m back home next week.

Is your copter electric or gas powered?

Cheers,

Andrew

Hi David,
It’s hard to select a single copter in Mission Planner. I loaded it in QGroundControl. Under Frame Class in QGC you can select Single Copter. From Frame Type select “Plus” - this is critical.
After you select Plus, you go to Parameters, Tools and click on Reboot Vehicle. You may also hard reboot it. I found this to be the most reliable way of loading all single copter parameters.

After that you can do all your calibrations in Mission Planner.
I know that you can select Frame_Class 8 in Mission Planner under Advanced Parameters, but I’m not sure how well this works or whether this is enough.

To check your servo functions under Advanced Settings, find Servo1_Function, and check if the assigned number corresponds to Motor1 (if I remember correctly). If not assign the Motor1 number. Do the same to Servo2_Function (assign motor 2), servo 3 and 4.

Please remember that you will not see the flaps move until you Arm the autopilot first, so you need to calibrate your copter or disable some features that are needed for Arming.
I’m not an expert here so please don’t be surprised if this info is not entirely correct.
Please let me know how it goes.
I assume you are familiar with this: http://ardupilot.org/copter/docs/singlecopter-and-coaxcopter.html

Cheers

Hi Andrew,
Thanks for that excellent advice! I’ve never used QGroundControl, so it sounds like that is a way to go. I’ll have to try it out. One thing I discovered that you mention, and I think this was half my troubles, reboot the board. I was getting frustrated because every evening upon returning to the project, the state of affairs was different and that was because the last changes I made before turning off the board would take affect.
This past weekend, I got the board armed got the outputs I was expecting. Just this evening I constructed a crude mock up of a SingleCopter. All functions as described except the yaw control seems to be really unresponsive, sure the control surfaces move, but a lot slower than pitch and roll. Maybe that is a function that will sort itself out in the air.
I also loaded CoaxCopter (Frame 9) onto the board. It functions as described except for yaw. When inputting yaw, none of the control servos move as expected, but the motors do not change speed as suggested in the documentation.
Thanks for your help. I’ll be posting photos and instruction of my build just so others can follow along this adventure. David

Hi Peter,
Would you be so kind and had a look at the log file I have attached. I am finally controlling the carburetor of the gas engine the way I need it, but after installing my single copter on a test rig for PID calibration, other things don’t work. I did not have these issues with my electric single copter. I’m suspecting that something went wrong with loading the frame type, or the latest software is not quite the same as older version I used in my electric copter.

To tune PID for pitch, the test rig restricts motion in all axis except for pitch. At rest the copter slightly pitches down. When I give it gas the flaps try to pitch it even further down instead of straightening it up. I have to grab it to prevent it from spinning around.
It is as if the direction of rotation of flaps is reversed - but it is not. Before arming the motor, flaps 2 and 4 rotate correctly. I did however had to reverse direction of rotation of flaps 1 and 4 but they play no role in this tuning (surprises me because in my previous copter (electric) all flaps moved correctly and did not need reversing).

I observed that after arming the autopilot, but before arming the motor, flaps will respond to radio commands for pitch and for roll but not for yaw. They will not respond to throttle either but that’s understandable.
After engine/motor is armed flaps do not respond to any commands from radio and adding throttle even a little bit sends flaps 2 and 4 forward, to make the copter pitch down regardless of copter’s vertical orientation (whether it’s tilted forward or not).

So my main question now is what cases the autopilot not try to upright the copter but rotate it in the opposite direction?

On a side note - in gas engines there is very little thrust till almost 3/4 of open throttle, so it would be helpful if the flaps got activated for auto mode at about 1/2 way up the throttle (or more). Is there a parameter that controls when they go into auto mode?
Log file:
Gas-single-copter-33.BIN (456.0 KB)

Thank you,
Andrew

Hi David,
With my newest single copter I’m also having problems with yaw. In fact, on a stand, I cannot make flaps move all in one direction to create yaw. I’m using the latest software and I’m thinking that it may have something to do with it, but I’ll wait till I hear from Peter Hall. His advises are right on the money.

What version of Arducopter are you using?

You said the flaps in your copter respond to the throttle stick for yaw. Just they don’t move a lot… Is this happening after you arm the motor, or before?
In my case the flaps do not respond to the yaw stick at all, but they respond to pitch and roll. Unfortunately my electric copter that flew well is in pieces so I cannot go back to it and check.

Thank you,
Andrew

getting outside my expertise now, I have never played with single copters. It sounds like a servo ordering or reversal issue. You should be able to run a motor test to check there ordered correctly. The other thing to check is that your RC inputs are correct, the green bars in mission planner should move in the same direction as the sticks except pitch.

Could you Peter recommend a person to discuss single copter issues, and how to contact him?
My RC inputs are correct.
When flap direction for pitch and for roll are correct, yaw is incorrect and flaps fight each other. Reversing direction of flaps 2 and 4 makes yaw correct but makes pitch go in a wrong direction.
I did not have these issues in version 3.2

There is another thing I would like to discuss with a single copter expert: the required motor direction for a single copter is CCW. Gasolines engines rotate CCW or CW - depending on engine. It is not possible to change this direction. Most gas engines in a single copter configuration will rotate CW so I wonder if there is a parameter in the program that could be changed to make a CW engine work.
Or perhaps it does not matter?

I think the sum of ArduPilot single copter experience is already on the forum, there are a few build threads maybe they would be able to help.

Can you confirm it works on the same model with 3.2 and with no changes to parameters it’s broken on 4.0. I would be surprised if we have such a big bug, that being said single copters don’t get tested much.

Rotation direction does not matter.

I found that the direction of the prop spinning, either CW or CCW mattered - at least in the SingleCopter software. I originally had the prop spinning CW (electric motor) and the singlecopter yawed out of control. Once I corrected it to CCW and changed no other settings the machine stablilzed correctly in yaw.

Thank you Paul. I’m very concerned that the algorithm takes into account the direction of rotation, especially during acceleration and deceleration of the motor. If that’s the case, there should be a parameter that one can change when using a CW spinning motor. Critical for gasoline engines that cannot be reversed. Peter thinks that the direction does not matter. Need to know for sure, otherwise I’m in big trouble.

logging at the code,

There is not change to the trust output with yaw. So rotation makes no difference. For a single copter.

If you were trying to fly a single copter on the coax copter code then it does make a difference.

Edit: in fact it looks like coax does not use the flaps for yaw at all, motors only

Thank you Peter!
Next what I will do:

  1. Will reload the Firmware Version V3.6.10 (or the latest) to the autopilot to verify the behavior.
  2. If no change, I will load the same firmware to my small electric single copter to verify. This copter flew well before, with the V3.2 firmware.
  3. If still no change, I will try to find and download the old V3.2 firmware and will load it to my small copter to verify.

May take me a week or so to do that as the small copter is in pieces. The large one with gasoline engine is mounted on an rig outdoor. It’s freezing already in my place so I’ll do most of the work indoor on the electric copter and will report the results.

I found the reason for my problems: the servos in my gasoline copter rotate in the opposite direction than those in the electric copter. I thought direction of servo rotation is standard.
There is still one thing I can’t figure out. In the 3.6.11 firmware Yaw does not work in my copter. The flaps will not move at all when I move the yaw stick. This is tested after I press the arm button and the red light turns solid. No motor is armed yet.

In my other copter that has the 3.5.4 firmware, yaw works. Same radio, same radio settings, but pitch, roll and yaw work fine. In 3.6.11 (different drone) pitch and roll work fine but there is no reaction at all to the yaw stick.

Hi Peter,
I wonder if you could help me out with two things:

1. In my new gasoline single copter, the flaps do not respond to the yaw stick until motor is armed. After arming the motor yaw works and the flaps move in the correct direction (obviously with some delay and not quite proportional to the stick because at this point the autopilot is trying to balance the copter). Firmware is 3.6.11.
The flaps do respond to pitch and roll though before arming (need to press safety switch first).
In my older copter (firmware 3.5.4) all three: pitch, roll and yaw respond to the sticks before motor is armed.
It may have nothing to do with firmware. Would you happen to know what parameters I should check/compare between the two copters to make yaw work before arming the motor?

The same radio is used in both copters. For the gas copter I’m switching direction of one channel in my radio because the servos rotate in the opposite direction.
The green bars under radio setup screen in Mission Planner move identically in both copters - exactly as you instructed earlier: all bars move in the same direction as the sticks except for pitch. Pitch moves the opposite direction.

I don’t know if it is critical to make yaw work before arming but it helps in making sure that everything is set correctly for a single copter.

2. After arming the motor, flaps start working only after throttle is above certain PWM. Which parameter controls the RPM that activates the flaps? I’d like to increase that value.

  1. I think this is hard coded, the thinking is that you don’t want to be trying to yaw on the ground

  2. Again I think this is hard coded, you can get always active stabilization by using a motor interlock

  1. This would mean that it has changed for 3.6 because I can try yaw in 3.5.4 on the ground. Frankly - if I can try pitch and roll on the ground, why yaw would not be allowed? Helps a lot during the initial setting. Lets you make sure the directions are correct, establish stops etc. Doing it after arming is not that easy and not accurate.

  2. The point is not to try to stabilize the copter before throttle is quite high, and better if it’s done automatically, not by a switch (that is if I understand correctly how the motor interlock works).
    When flaps are active before the thrust is able to lift the copter, they tend to tip the copter over because landing legs hold the copter while auto is attempting to balance. In a single copter the copter must be in air, nothing touching the ground in order for the flaps to do their job. The bottom of craft must be able to move freely. When flaps start balancing prematurely they just create a side force that tips the copter over. The same during landing. It’s like stepping on you shoe laces :smile:
    This is why I was asking if there is a parameter that allows to delay that till throttle is further up.
    So far the only option was to give a single copter almost a full throttle right away to make it jump of the ground. Not the best procedure for take off. A gas engine is more sluggish so I expect problems here.

If you let go of the roll and pitch sticks it goes back to being level, if you let go of yaw it will still try to yaw to the new heading. ie angle control vs rate

Falling over on take off and landing is a difficult problem to solve for all copters, aggressive takeoff do work quite well, I cant think of any parameters that would help, but there maybe one

Hello gentlemen,

I am setting up a coaxcopter now and seem to have forgotten how to get the setup going. Maybe you guys having done it more recently can help me with some secrets.

Acelerometers and compass calibrated, battery failsafe set very low, and arming rules relaxed. Receiver signal is good, telemetry is good.

I can arm the system, and advance the throttle stick to some mid position. But it disarms after a minute or so.

While it is armed, the flap servos do not move. I want to check thta they go in the proper directions in response to pitch and roll changes.

Do I need to have the motor ESCs plugged in?

Update and Solved: I needed to apply a 5v source to the servo rail to power the servos. Sheesh.

Thanks,

Paul

Servers by jDrones