Servers by jDrones

SimpleBGC, MavLink control, Yaw


(Tim Jones) #38

currently searching for a mini pro, ready to throw my storm32 in the kibitz drawer


(OldGazer) #39

What problems are you having? I have a STorM32 and it works just fine…


(Tim Jones) #40

Storm only really works if you use openbeta a fork of arducopter. Not interested in forks
probably not the thread for that long discussion


(Danijel Petrović) #41

hello everybody …

I am just about to finish one new setup … but old problems sems to come out of box once more …

I have connected infinity mrpro via mavlink to px … , and under mavlink tab in BGC everithing is OK , except control NO …

have enybody found solutin … is this px fw issue? , since it was all working fine whit AC V3.5.3.


(Nathaniel McMahon) #42

I never got mine to work, my psychiatrist told me I should stop trying. I’d love to see your settings of you manage to get it going again. Best of luck.


(Danijel Petrović) #43

heh … my wife told me get some other job… but it is fustraiting to see how whit newer fw some thing are not working as they ware whit old ones …

I get AHRS ok ;GPS ok; RC ok; but control NO ,
there is no visual hardbeat on gimbal controler board …


(Danijel Petrović) #44

actualy It is working whit single wire,( mavlink tx form px) , perhapse that is reason for control no


(Danijel Petrović) #45

I got it workinggggg …


(Nathaniel McMahon) #46

Can you do is a huge favour and post some screen shots of the basecam settings? I’ll give it another go. What was the issue in the end?


(Danijel Petrović) #48

sorry for waiting ,
I think I have made wrong connection for mavlink rx on First atempt,
so now this is how it is all working ,


(Nathaniel McMahon) #49

That’s brilliant Danijel. I’ll have a go this week


(Danijel Petrović) #50

I am shure you will be sucessfull
this days I will give my best to try mavlink on tiny board w encoders…


(Nathaniel McMahon) #51

Haha now I’m totally confused, those yellow, blue and white cables are plugged into fc_roll, fc_pitch and AUX1 respectively.
So that’s AUX for one way mavlink connection? Surely not using FC_roll/pitch ??? never heard that mentioned.


(Nathaniel McMahon) #52

Nope still nothing!!

Here’s my complete setup

without pins I’ve connected to as I’ve tried them all.


(Danijel Petrović) #53

ok , lets do this one more time …

put mavlink tx on RC YAW (on mine picture blue wire directly soldern on board )
put mavlink rx on RC ROLL (on mine picture yellow wire directly soldern on board)

set telemetry port to 115 , protocol mavlink 1 , choose storm32 on gimbal page of MP optional hardware , set mnt_rc_in_roll to some chanel , do the same for tilt and pan …

please check BRD_SER(PORT NO:)_RTSCTS

disrigard all other wires …


(Nathaniel McMahon) #54

Sigh,checked double checked. brd_ser2_rtscts:0. Nothing, I reset every time. I’m guessing the the simple bgs will just pickup the mavlink connection in the green lines on the mavlink tab, at one point i got 512 packets received but don’t know how or when. It could be working but the gui doesn’t show it??
I’ve sent an email to Jakub at hdair studio and see what he says.
Tried three different firmwares. Tired.
Thanks again for your help Danijel!


(Nathaniel McMahon) #55

On the other hand I added a bluetooth adapter via the serial port which was a doddle comparatively. Using the Basecam android app is great. The control mode is pretty, gimbal follows you phone direction, actually very impressive.


(Danijel Petrović) #56

I am looking around how to connect tiny board to mavlink , since it has no rc roll input witch I have used for mavlink tx , can I asumme I could just plug mavlink tx an rx to tiny board TX and RX pins that are specified as uart to bluetooth…


(Nathaniel McMahon) #57

I was thinking of using the serial port for fc mavlink. But for some reason in the literature is not mentioned as another channel for mavlink, or as a uart port. It’s buad rate is 11500 by default so good there. The simple BGC manual is pretty good. It says the tiny has rc_roll and Rx on the same pin. Surely it has rc_roll? Simple bgc_32bit_manual page 38


(Norimbo) #58

Hi Iam trying to connect alexmoss board via gps2 port (telemetry4) on pixhawk 2.1 (cube) Anyone knows why I don’t have sr4 and sr5 parameters in missionplanner ? They don’t exist in mission planner :frowning: