SiK module lost connexion and cannot recover

Hi all,

I have an issue that is driving me mad…
I (with a team of 5) have been building and flying a F550 on ArduCopter for a challenge.
it is using a SiK module for communicating with the ground.
Unfortunately, we recently had issues when connecting with the telemetry modules (it connected to the copter : green static LED, but not with the computer on both Windows and Linux).
So we decided to upgrade to a newer version of the SiK firmware (2.0) with QGroundControl. Only, after updating the ground module, QGCS reinitialized the net_ID of the module, as well as all its other parameters, and of course, we lost the connexion with the air module for good (blinking green LED), since the parameters are not the same on both modules (we didn’t think about saving the parameters beforehand).
We also discovered that there is no way of connecting the onboard module to the computer via the PixHawk board. So we tried connecting the module with a USB-to-Serial adaptor (from an Arduino board), but didn’t manage to connect.
Would there be any other way to set (or reset) parameters, or update it the air module in order to regain connexion with the ground module ?

I found a PixHawk passthrough to update the module, but it’s getting quite old, and didn’t work for me :slight_smile:!msg/drones-discuss/-AhcK5G0FPQ/gib6MrespgUJ

Here is the USB-to-Serial adaptor I used (sorry, it’s in Indonesian):

& also tried with this resistance mod:

Btw, I tried on all those platforms:

  • DroneKit (Ubuntu)
  • QGroundControl (Ubuntu)
  • APM Planner 2 (Ubuntu)
  • Misssion Planner (Win10)
  • Sik Radio Config (Win10)

Thanks in advance !

Nevermind, I finally managed to connect to the air module with the arduino, via wires directly soldered to the IC (to avoid the resistance).
Anyway, I still think it would be a great idea to be able to flash an onboard module via the USB connexion of the Pixhawk to the computer… Tbh, I’m a bit surprised it doesn’t exist yet…