Severe wobbling and oscillation before aircraft lifts off the ground

First flight attempts 5" HexaCopter using H743-mini. I try to take off and experienced severe wobbling and oscillation, immediately and before aircraft lifts off the ground.
I also noticed that all the commands in all the axes are reversed (roll, pitch and yaw). The FC is positioned correctly and I did an accelerometer calibration on the three axes.

I’ve start with:
PID Controller Initial Setup:
INS_GYRO_FILTER : 80Hz (for 5 inch props)
ATC_ACCEL_P_MAX : 162000 (for 5 inch props)
ATC_ACCEL_R_MAX : 162000 (for 5 inch props)
ATC_ACCEL_Y_MAX : 27000 (for 5 inch props)
ACRO_YAW_P: 0.5 x ATC_ACCEL_Y_MAX / 4500 (0.5X54000/4500=6. I was not sure, so I left it at 4.5)

For Copter-4.0 (and later):

ATC_RAT_PIT_P, ATC_RAT_PIT_I, ATC_RAT_RLL_P, ATC_RAT_RLL_I = 0.135 (end at 0.04)
ATC_RAT_PIT_D, ATC_RAT_RLL_D = 0.0036 (end at 0.001)

I started at 0.0036 and 0.135 respectively and reduced each attempt by 50%. I finished at 0.001 and 0.04 respectively (lowest values). As I went down in values the oscillation aggression went down, but even at the lowest values I could not leave the ground.

Attaches the parameter file 15-may-21-back to V4-1.param (19.8 KB)
Thanks for your time,

I would put INS_ACCEL_FILTER back up to 20
and use this spreadsheet for setting those initial params, in this case you are missing the MOT_BAT ones. Ensure the voltage monitoring is working correctly, and current monitoring if you can.

The Rate PIDs should work reasonably around 0.08 for P and I, and 0.004 for D terms.

And try increasing
to as much as 8 or 10 and see what effect it has.

But next step is more testing and supplying a .bin log file instead of just params.

Thanks for the response, I really appreciate the help.
Now is the middle of the night, I will check the changes you will recommend tomorrow.
The voltage and current values on the DATA screen look fine, I will check this again.
Do you have any idea why all the stick commands on all axes are reversed (roll, pitch and yaw) or how can I fix it?
Attached BIN file.
Thanks for the help, I will report tomorrow after checking and changing the recommended parameters.
2021-05-13 18-13-58.bin (553.0 KB)

After updating parameters there is some improvement, but still fails to take off.

Attaches a BIN file.
2021-05-16 14-19-42.bin (588 KB)

Can motor alignment cause such great instability?

The motors are not symmetrically arranged on a circle around the center of the FC as in the “classic” HexaCopter, they are a bit arranged like H. Attaches a picture.
Motor alignment

That’s fine. Hex-X will work. Did you perform the Motor Test in Mission Planner?

Which direction is the USB connecting facing with your AHRS_ORIENTATION set to 6?

If this is the first flight how did you come up with the Rate PID’s you have?

The Barometer needs protection from prop wash - the flight controller thinks it’s going DOWN when you throttle UP.

1 Like

Yea, as Shawn said put some foam over the baro. I have a H743-Mini in a 5" and I sandwiched a piece between the FC and the ESC. It works pretty well.

Thanks Dave, you are awesome!

I did not notice that AHRS_ORIENTATION is set to “6”. The FC is installed normally. I changed the value to “0”.
After changing the AHRS_ORIENTATION I was able to take off and hover without the wobble.
Both axes ROLL and YAW are fine, the PITCH is reversed. It is not clear to me why and how to fix it.

I will protect the barometer with a foam, is it on the side of the SD card?

I started with the PID that came up by default:
Do you recommend to start with different values?
Attaches a BIN file from the short hover.
Thanks again for all the help,
2021-05-17 02-22-23.bin (624 KB)

At this point I was thinking of running auto tune. Do you think this is the right step or should I do something else?

Ok, I found the barometer … :slight_smile:


These are not default so wondering where they came from? That along with the AHRS Orientation is suspiciously like this has been monkeyed with before.

Reverse the pitch channel in your transmitter, This is commonly required.

And no, not ready to run Auto Tune. You should set the Dynamic Notch Filter 1st. This requires a couple short AltHold flight with some parameters changes along the way. Wiki is here:

Make an attempt at it and come back with questions.

And-You have a Dshot protocol set but ESC telemetry is not configured. Motor RPM from telemetry is the way to go for the notch filter, so configure it. Actually Bidirectional Dshot is an even better option which runs on these FC’s if you install the right firmware and configure it.

You have an H743 so take advantage of it.

1 Like

Do you mean that 10 is too high? I started at 4.5 but in the first response above, suggested going up to at least 8-10 … Do you suggest going back to 4.5?
That’s what I did. I reversed the pitch channel in my transmitter, but I thought it was not the right way … to fix the problem.
I will try to fix the things you recommended tomorrow and come back with an update.
Thank you,

No way to know with where you are with this craft. Perhaps it’s to low… Auto Tune will sort that, if you get everything else set. I would put it back to default.

Reversing in the Transmitter is the right way. But perhaps it’s confused with the wrong AHRS orientation parameter?

Thanks Dave,
Can you please explain (or send a link to WIKI) about ESC telemetry? I use BS13A 6in1ESC and it has no communication port, at least not one I found. Or did you mean something else?

Nevermind then, tha appears to be a BLHeli_S ESC. Telemetry is available on BLHeli_32 ESC’s.

Out of curiosity, after you connect to Misison Planner and on the Messages Screen what does the Banner Message say for RCoutput protocol? As an example here it shows:
RCOut: DS600:1-4 PWM:5-6

1 Like

RCOut: DS600:1-4 PWM:7-13

OK, so Dshot is good. I see you have the Bidirectional version of firmware installed. No problem with that but to use BDshot with a BLHeli_S ESC requires custom firmware installed on the ESC. I have a craft flying that way. I’m not sure if there is a custom version for the ESC you have.

I did not find another version. I also do not have the ESC’s Pinout for connecting telemetry, it’s a pretty closed FlyWoo product.

Today was a good day!: I flew in AltHold. I flew at MOT_HOVER_LEARN = 2, do I need to return to “0” after this flight?
I also checked Loiter and RTL. Despite the strong wind, everything worked fine.

Tomorrow morning, I have no wind. I will check the Dynamic Notch Filter and then AutoTune.
Thanks for the support, I really appreciate it.

Another question: I use CROSSFIRE to enjoy telemetry. I installed YAPPO but do not get the data on the radio. Do you have a direction to check? The MTEK website says (Crossfire support only exists in “latest” 4.1, not stable 4.0.x, if you load “latest” then Set SERIAL7_PROTOCOL = 23, RSSI_TYPE = 3) and that’s what I did.

Can you please send a link to WIKI?