Several problems reported in Mission Planner, no gps etc

I previously reported a problem with the left pot of the TX not working, and was lucky enough to have a friend in Bolivia fix it for me. I now have several new problems (which definitely did not exist before), which I am thinking may be related to American Airlines Baggage Throwers. I recently flew from St Thomas in the USVI to Bolivia where I live, I transported the IRIS+ in one of those fancy custom cases so I thought it would be all protected, however on arriving in Bolivia (and solving the TX problem with my friend), I now have several new problems:

  1. On arming the copter the STATUS indicator light does not light at all ZIP, NADA.
  2. If I arm via the transmitter (left pot down right) the drone makes a sad boop-beep noise and does not arm.
  3. Mission Planner reports two errors in big red letters:
    i. GPS: No GPS
    ii. Pre Arm: Compass offsets too high.
  4. I have tried configuring the compass using mission planner initial setup, and noticed that both compass 1 and 2 initially report as error 99, then compass one says error (x) with x being an ever changing set of numbers. Compass 2 continues to report error 99. After completing the calibration the errors reported in Mission Planner continue.

I guess my questions are:

  1. what might be going on here, how can I trouble shoot it?
  2. I can’t see GPS calibration in Mission planner, is it in there somewhere?
  3. could this at all be caused by simply a loose module inside (after the baggage handlers finished tossing the drone box around?).
  4. Anything to do with me being in another hemisphere now?
  5. oh, and off topic, what is the minimum voltage the TX unit should have to still be working?

thanks for your help.

Have you tried taking the cover off to check the gps/compass module is still connected and powering up?

Mark, I removed the cover, peeled off the shield and there are no visible led’s when the drone is powered. I couldn’t see exactly where the led status lights might be on the board, nor could I see something online as to where they are? assuming they are on the circuit board side, I think this would indicate that the GPS is not powering up? or am I wrong? using the configurator for the compass via mission planner, I was getting readings (although it still reports compass offset too high). do you have a link to a picture of where the different status lights are?

Also, I’m not sure if it was clear, GPS lock had been achieved several times before I flew to Bolivia, so at one stage th GPS unti WAS working, it is possible it would just burn out?

Thanks for the help.


Also, I loaded the u-centre software into my computer and connected, and it reports no fix, and the following error when trying to get information from the gps:

Polling: MON-VER - B5 62 0A 04 00 00 0E 34 …
… timeout occurred without receiving an answer. Retrying…!
Polling: MON-VER - B5 62 0A 04 00 00 0E 34 …
… failed due to timeout!

etc … htPipe.jpg

Pretty good picture I found via Google image search, red led shows power and it looks like there is another led below it showing “gps fix”

I wouldn’t say it’s impossible for it to have just died but if the cables are plugged in firmly at the gps end and the pixhawk end then I would be using a multimeter on the cables (unplugged from the gps end) to check for a voltage going to the gps. If there is voltage then the gps is dead, if there is no or low voltage then the problem is pixhawk end.

You are definitely a better google ninja than me! Ok, I DEFINITELY do not have those lights showing. I have a buddy with a tester, I’ll try and borrow it and figure out which end the problem is at. Pretty frustrating after having the TX problems as well. thanks.

I use DroidPlanner 2, I almost always get a few missing Calibration issues after I’ve transported my Iris+ a considerable distance (50-150 miles), and on first power up. I disconnect the battery at the Iris+ for 10 seconds, then reconnect and DroidPlanner (the Iris) stops complaining.

I spent some time today with a friend and a multi-meter we tested all the cables and they work fine.

we also tested output from the 12C plug on the APC, this seems to have no power coming out of it. Is that possible/correct? If I remember correctly the GPS plug was giving out 3.6v roughly.

if anyone could tell me exactly what to test (ie which of the plugs and what voltage they should be showing) that would be really helpful.

Just to be very clear NO LIGHTS are showing on the GPS module, neither PWR nor FOX. NONE.

What would be the next step on this.

Sounds very similar to the issue I had. If you have two mini USB Cables hook one to the Arducopter board and one cable to the GPS. If the GPS lights up after all the drivers are loaded go into the UBLOX software and there is a setting under USB that you need to change from USB to Self Powered. Then click send in the bottom left corner. Then you have to go to the top menu and save the config. Unplug the USB and it should stay on…

Hopefully that might help…