Setting up Telemetry over CRSF

This is my first build so please bare with me. I may have some fundamental flaws in my understanding.

I am trying to get some telemetry info to show on my Taranis X7.

I am using a Taranis X7 with mod to allow CRSF full speed. TBS crossfire TX (fullsize), TBS nano reciever, F405-wing, ardupilot. Everything was flashed in the last week to most up to date.

TBS Tx is set so Ch1 and 2 are CRSF to the F405-wing serial1 serial1 protocol = 23. Everything works well there.TBS rx Ch3 and 4 go to TBS unify evo VTX via CRSF. Everything works well there.

Somehow I think we are supposed to be able to get RSSI and/or LQ back onto the X7 telemetry page? In missionplanner I have set RSSI_type = 3. Trying to search for new sensors on X7 gives me nothing. Not understanding telemetry at all, I then set nanorx ch.5 output to RSSI/LQ. Still nothing. I then set RSSI_Channel in mission planner to Ch 5. Still nothing.

Can I get some basic telemetry back to my X7?
Why the heck would telemetry need an output ch? especially when the two way data is ch1 and 2
What am I totally misunderstanding about telemetry/rx channels?


Do you get telemetry at all? Your setup sounds correct.

We don’t publish RSSI via regular CRSF, but the TBS firmware should.

I don’t think so but I could easily be looking in the wrong place or have something configured wrong. Should I be going to opentx telemetry page to discover/find new sensors?

Why does the Rx need to output telemetry ok n a different channel than the crsf already going to fC?


You only need the RX/TX connection to the flight controller for telemetry to work

Ok so I can disable the RSS/LQ on the RX settings. Where would I go to enable or try to add to opentx telemetry page?

On the RX setup I also see RC by mavlink is on…not sure this matters.

Yes. Add sensors is where it is supposed to happen, but I use yaapu which publishes RSSI in a different way

Thanks Andy. I am totally new so I’ll have to read what yaapu means. Maybe that will work better for me?

From reading it sounds like I should be getting SOME sensors when hitting discover sensors on opentx…nothing comes up which makes me think I have something setup wrong or there are additional settings I am not aware of?!

Anyone have a setup guide for idiots for getting telemetry from Ardupilot to opentx using CRSF? I see lots of inav but nothing for ardupilot.

I see something called RC_options in the parameter tree that has entries like passthrough for CRSF telemetry or some such. These aren’t mentioned in the setup wiki though.

If RC input is working then telemetry should be as well. You should not need to set any options. The only thing you need is one of the serial ports set to protocol 23.

I did a video series that takes you through build to configure to tune for copter. It uses CRSF - plane won’t be much different: ArduCopter 7" LR Build Video 1 - Intro and Unboxing - YouTube

Nice videos! I am definitely a beginner so some of it I didn’t totally follow.

Still not sure why my taranis isn’t discovering any sensors. Maybe I should try flashing it again with a different firmware version?

Can you post a clear photo of the wiring between your receiver and flight controller, and also of the Crossfire LUA output screen?

Ch1 should be CRSF TX and go to RX1, Ch2 should be CRSF RX and go to TX1

That’s another funny thing. I loaded an ad card and slapped it into x7. I get a voice talking to me now but nothing happens when I try to execute Lua crossfire Lua scripts from SD card. I’m totally new to this so I’m a bit lost.

Follow this guide to install TBS Agent Lite on your radio and confirm the CRSF output settings:

Ok I am confused. TBS agent lite just keeps looking for devices…none found. However my RC outputs are picked up by the crossfire tx and received by the nano rx?

So maybe there’s no feed back from TBS tz saying it’s there? Possibly a crummy mod job? Although it was a pretty straightforward job?!

It is not clear what you mean by this. If both Ch1 and Ch2 are set to CRSF TX, you won’t get any telemetry back from the flight controller. Ch2 must be set to CRSF RX and connected to TX1 on your flight controller.

If your radio can’t communicate with the TX module, that will be an issue as well. Try contacting TBS support and see if they have any ideas.

Apologies. The TBS crossfire tx module (with screen and joystick) is bound to a tbs nano Rx. Using the TBS tx joystick I can confirm that the nano output 1 is CRSF TX. Output 2 is crsf rx. Ch1 and ch2 are wired to Rx and TX respectively on the Matek f405-wing ( tx to Rx, Rx to tx).

The nano ch3 and ch 4 are crsf Rx and TX respectively and are connected to a tbs unify Evo vtx.

I am beginning to think it must be something between the taranis and crossfire module. As everything from the module on seems to be working (although I don’t know how to tell if nano Rx is trying to send any telemetry back to crossfire tx module).

I saw this video where so.eone with far more electrical know how found he wasn’t getting enough power to one of the pins? CROSSFIRE IS WORKING!!! | Inverter Mod Issue Taranis QX7 Fix | FrSky R9 to TBS Crossfire Part 3 - YouTube

No one has had issues getting any/all telemetry back to taranis qX7? I’m getting desperate. I might desolder the diode in above video to see if that helps.

If you’re unsure about the qx7 mod you can install EdgeTx and turn on one bit mode. But even if the mod wasn’t working you should still see some sensors and hear that warning sound, but they will come and go I think. If you don’t see any sensors at all and its got a green light on the Rx showing its bound and connected then its definitely not related to Ardupilot. I would review the setup manual for the crossfire tx and see if you missed a step. Something like having the qx7 not set to crsf for the external module could cause these symptoms. You could also try setting the baud rate to 115200 temporarily on the qx7. The crossfire tx will auto sense the change and give you some sensors if I remember correctly and that could help you figure out where to look next. And make sure to do a new “search for sensors” on the telemetry page after each step you try. I’ve also got a qx7 with the mod so I feel your pain.

Hi everyone. Figured it out last night. Somehow the inverter was toast. Could be I fried it during installation as I’m pretty sure I was drinking. Rotorgeeks had me a new one in about 3 days and the new one has fixed my issues!