Setting up RSSI with pixhawk, minim OSD, and EZ UHF

Hi all If there is a grand wizard out there who might be able to help It’d be greatly appreciated. I’ve run into a few issues trying to set up a minim OSD running Night Ghost firmware and an EZ UHF on a traditional Helicopter running 3.4. The biggest issue I have is that with traditional heli, channel 8 is already assigned for throttle, where through the config tool for the the minim OSD channel 8 is the only option available for reading RSSI from the receiver, the third leg to the issue is that with EZ UHF to get RSSI through ppm you have to assign the channel (which I’m guessing has to be channel 8) you want to carry across the RSSI or link quality information. Is there any way to use a different channel for either RSSI on the minim OSD or for throttle on traditional Heli?? The other issue I’m having (it could be related to the first) is that when humouring the system and ignoring the throttle issue for a moment, just to see if I can get it working through channel 8, I’m not getting any reading for RSSI at all on the screen. It just reads flat 0 even when switching to raw values to read the extremes for when the radio is on and off to find the end points of the range. All it shows is 0. Has any one else used minim OSD with a traditional Heli, EZ UHF and a Pixhawk? No doubt there is probably something I have missed in the config tool for the minim as well so any wisdom that could be imparted would be hugely appreciated… I understand that this monster I have been presented with is one with many heads covering a range of topics, which makes it hard to place so apologies if not all of it is relevant here.
Many thanks in advance.

It doesn’t have to go through channel 8, if can be any channel above 4.
I have mine set to 9 (on DTF UHF/OpenLRS).
RSSI_CHANNEL: (your channel)
RSSI_ANA_PIN to 103 (on a Pixhawk)

Connect with mission planner, make sure that the rx-rssi shows up in the hud and that you get a reasonable value.
As for Minimosd, it doesn’t care about which channel, as it gets the information from the pixhawk via the serial port.

Thanks mate. I’ll have a look at it when I get home.

I had another look at it, I’m not getting any RSSI value through at all still. I have link quality set to ch 6. I set the RSSI parameters appropriately in the parameter list… still nada. Any other ideas?

I don’t really know ezuhf, but this seems to suggest that it should be set here:

Also, are you on a Pixhawk or APM?

Thanks for the replay and sorry for the delay in getting back. I was on a pixhawk but was having major compass calibration issues I think something fried during the last crash I am rebuilding from so I ended up getting a pixhack, for the heli as you know 3DR no longer are producing pixhawks and I liked the idea of internal dampening. Anyway, I managed to get everything up and working properly with a pixfalcon on a sky walker, it turned out I had a setting wrong and was looking for RSSI on the wrong input. I was getting RSSI in mission planner but nothing through the OSD, I changed the settings into get RSSI from FC and was away laughing. I now have it working on the heli too. The only hiccup I need to sort out is the OSD page toggling via the flight mode switch, on the heli. It’s working fine on the plane.