"setting new offsets for compass #1 failed"

I had the same problem with an Arduflyer 2.5.2 and Ublox Neo M8N. I got a new transmitter and receiver so decided to re-run the wizard, and kept getting that compass #1 failure message after running live calibration. After about two days of pullout out my hair I realized it had to be a software glitch. I downloaded Mission Planner 1.3.9 and it calibrated fine, but 1.3.9 is a bit dated. Anyone know how to get the latest software just before the most recent update?

Got the same problem here, so downloading a older version of mission planner could solve? Where to download it? Or should I just wait? Wish this will fix soon to lift off my first drone.

Here: http://firmware.us.ardupilot.org/Tools/MissionPlanner/
Archives. Newest software is at the bottom.

So have learned a few things while troubleshooting thus since I first posted, most importantly though for anyone in a hurry is that the compass calibration is actually working fine as far as I can tell. I have come to this assessment based on the fact that in final pre arm checks, The Co mpass Cal step is shown as complete. If anyone is still having trouble and not passing pre arm, here is a couple things I was told to try, wether these things were a factor in mine working or not i have no idea… 1. Is to disable the auto complete option inside of the calibration I interface. This allows you to take your time and make sure you successfully eliminate all the white targets, and again not sure if it’s of any help but I made sure the error count was at 0 before I clicked ok. Once I did I got audio feedback that calibration was successful while still receiving the same unable to set offset error. So just ignore it in this case. 2nd thing I was told to try was to disable the magnet option in parameters.

Now, the part of this I didn’t like so figured out for myself, Is that I remembered when first doing this, after calibration, it had set a couple offsets for the compass. This time, while the compass was calibrated for accuracy, the offset values weren’t filled in. If you see in the top box though there is a link to the website which will give you these values. They are assigned based on location, not hardware sensor. So you just un tick the box that says set automatically, get your values by entering your local on the site, and then plug them in. Done deal
, Compass in good health!!

please try the latest beta MP.
this should be fixed now.

Will do.
My Workaround (in the last 24 hours) was to load up the latest APM planner and just run the compass cal. in that

What was the problem? What had to be fixed in the latest version?


Thank You.

the settings where saving, even though it displayed an error.

the reason was its trying to set a parameter that doesn’t exist on old apm firmware

1 Like

I had no clue it was actually something like this.
I also had no clue I’d get a response this fast let alone a fix!
Was so worried that I was on old stuff and in ‘unsupported’ or at least ‘un cared for’ territory.
What timing.
My very first APM haha.

I’m new to Ardupilot but have an alright handle on what’s going on.

Fun stuff.
Thank You!

Also, just for the record, APM hardware is VERY VERY OLD and NOT SUPPORTED. Please, everyone, stop buying them when about the same price you can get a pixhawk or a pixracer. I hate to say it but there are plenty of clones of these boards available too.

Get a pixhawk (of some sort) , and you won’t regret it… many cool new features,

pixracer: smaller hardware for smaller airframes with less features and lower cost
pixhawk: well proven mainstream hardware , also called "pixhawk1"
pixhawk2: latest and greatest pixhawk version, used in the solo, and now being sold on their own.
( other hardware’s are also available, but these three are the most popular options)


Good advise. Thanks!!
I bought the 2.8 about 1 year ago not knowing anything for $40 US.
Just figured at the time it would be fun to play with.
My expectations of performance are not very high.
But figured it would work at a minimum and still be a good intro.

But yes advice taken any new or serious projects will be based on newer supported hardware.

For me this 2.8 is just a let’s check things out type project.
And to be flown/tested away from people and property in case it does not work so well.

@DavidBuzz I would agree that APM is getting dated, is now unsupported, and that new users buy pixhawk instead.

On the other hand I would like to point out that there are still thousands out there still working fine.
We have many in the field doing commercial work that just keep keeping on.

So I guess what I am saying is, don’t dismiss the APM out of hand due to it’s age.
They still do a good job.

On the plus side, once an APM is setup with AC 3.2.1 there is no need to keep upgrading it for a new FW version that might have the latest bugs fixed :wink:


Lo que les interesa ustedes es que compremos la pixhawk supongo que tendrán buena comisión ( y me alegro por ello) pero los que estamos usando APM pues nos disgusta que por falta de información,o que no le interese a ustedes que siga funcionando y lo que estan intentando es que nos compremos la dichosa pixhawk seguro que es muy buena,pero en su momento y hasta hace unos meses tambien lo era APM.
Asi que en difinitiva si tengo que cambiar de controladora no será una pixhawk, tan solo por dejar de lado a la gente que estaba a usar APM,saludos y que disfruten de su pixhawk

It’s not that people make money from selling PixHawk’s

The APM is a very limited 8 bit platform, and to keep improving the features available on ArduPilot, a new 32 bit platform was designed a few years ago. This evolved to be the PixHawk, which has evolved, maintaining compatibility, to the PixHawk2.

Even after the PixHawk was released, the support for APM was kept, but at the moment the new features are not possible to port to the APM, and as the team is very small and supporting the APM was extremely time consuming, it was decided to stop supporting the APM.

Nothing to do with financial interests, only technical.

If you choose to buy a APM today, it is a decision that you must be aware of its limitations. Some of us still have APM boards (I don’t), and I still use a MultiWiiPro board with a hacked version of ArduPilot. If I have a problem on the MultiWii, I try to solve it by asking or learning the code.

Do you know someone that still uses a PC-XT machine? It’s the same. Things evolve and older systems stop being supported…

Es mejor escribir in ingles. Perdona por mi castellano :slight_smile:

1 Like

I use APM still successfully in Arduplane. APM 8 bit is still much better than DJI Naza V2. For people who want to deal intensively with the topic is the inexpensive APM ide

So, I keep getting the same failure. It seems to happen when I turn my copter upside down in order to capture the white dots in the lower hemisphere. I am using Mission Planner V 1.3.44 and V4.4.4 quad firmware.

You indicated that one should disable the auto complete option inside of the calibration interface - can you be more specific? I can’t see where I can do that.

Está bien publicar un mensaje en español.

@FossilRider there is no V4.4.4 copter firmware.
If you have an APM then the firmware version stops at v3.2.1
If you are loading anything later then that will cause issues.

If you have a Pixhawk then the current release version is v3.4.4
You could try downloading the beta release of Mission Planner which has some fixes in it for compass.

Same, I bought mine actually in 2014! LOL, just barely got around to building it. Now after the first couple of flights I am hooked and already looking in to better systems. Even though the 2.6 that I have is awesome, I am getting all kinds of new ideas for things to integrate if there was a full Linux stack on board. Anybody have any advice or comments on the Navio2? Seems that this would blow a Pixhawk system out of the water… RasPi3 + Navio2…

Well, I will try again - perhaps I wrote down the firmware version incorrectly. At any rate, I have an older version of M.P. loaded on a laptop and I tried to do the compass calibration on it, but goto the same results. I know that the compass/GPS unit is good, so I decided to swap flight controllers. The unit I swapped out is brand new (well, I bought it over a month ago - been waiting all this time for a new GPS module). Anyway, the compass calibration was successful.

So now, I’m suspicious of the F.C. I will reload the firmware and try again. If it fails, I will toss the F.C. and get a new one.

I downloaded the firmware from Mission Planner, build 1.1.6250,35577. I selected APM Copter quad (x-config), which was listed as V3.4.5. The download was successful and I sucessfully completed the accel calibration but the compass calibration remains a problem. Mission Planner says it was completed, but I still get “Bad Ccompass Health” indications.

If I am getting Pixhawk firmware instead of APM (Mission Planner should be able to detect the difference), then I would expect the download to fail as the image should not fit in the APM.

So, I think I’ve run into two problems here:

  1. The “setting new offsets for compass #1 failed” problem that others reported, and seems to be fixed by updating with the latest beta code.

  2. A problem with my flight controller either not retaining the compass offsets or something else.

I can try reloading the firmware from the older version of M.P. I have on my laptop, but I’m beginning to think that it will be an exercise in futility, and I’m getting tired of swapping out flight controllers between my two copters.