Setting Minimum spin confusion and throttling

So I am using the pixhawk 2.4.8 on Mission Planner. I can set the Arm speed (currently 8%) on both the Motor Test as well as ESC Calibration sections. The issue is the Minimum setting. I can set the Min on the ESC Calibration section, but not in the Motor Test section. Is this something I need to worry about?

Sidenote: is there a setting that slows down / softens the throttle transitions? For example, going from idle (8%) to 15%, will it be instant always, or can I set it up so it goes from 8% to 15% over let’s say 2 seconds?