Set COMPASS_ORIENT Failed!

Hello!

Im having trouble with the compass.

Multicopter: 3DR flat Hexacopter (Event38 Aphex)
FC: 3DR APM 2.6
GPS-Compass: 3DR UBlox GPS with compass
APM:Copter 2.9.1b
Mission Planner 1.2.98 build 1.1.5187.14200 (problem is also in newer version)

The multicopter flew bad and was sent back. It returned and compass calibration wont work.

In Mission Planner, Initial Setup, Mandatory Hardware, Compass:
When I try to choose “APM with External Compass” I get the error message “Set COMPASS_ORIENT Failed!”.

I can do a compass calibration after that, but it turns out to not work good at all. Compass lives its own life.

Why do I get the error message and what does it mean?

Have tried different computers with differens Mission Planners and also changed the uBlox. No differense. Anyone have any good next step to try?

This one is solved.

  • Upgraded to a newer firmare (without knowing if that could affect the setup): Orient Failed-error message gone.
  • Loaded parameter file: Orient Failed-error message still gone…
  • Fingers crossed: Orient Failed-error message … still not there. =) Compass works as it should.

I have read some where that 2.91 doesnt support external compass…

New problem after some flying: The hexacopter shut off in the air and fell down. But thats another issue, probably a brownout for the RC-Receiver.