SD card not detected issue on Pixhawk

I’m using a brand new pixhawk 2.4 board with its original 2Gb SD card.
It has booted fine for the first few days of use. (and the multicopter flew fine)
However today the Pixhawk FC could not boot, ringing the “SD card not detected” sound (BEEEP-BEEEP-BEEEP-beep-beep-beep).
I tried removing and re inserting the card many times without success. In the meantime impossible to connect by USB and/or by telemetry on Pixhawk.
I then tried to remove insert by small rubbing movement in order to “brush” the contacts between the Pixhawk SD slot and the card, then it worked again.

This is a critical hardware design issue because it is erratic, unavoidable (electrical contact problems). What would happen it suddenly these bad erractic contacts happen ion the middle of a flight ?

I’m afraid now of the lack of reliability of Pixhawk because of that ~#{#[{ SD card design. Is there a way to configure Pixhawk to avoid completely the use of this SD card ? (and just use undestructible/vibration insensitive internal flash memory?)

Sounds just like the original problem of Flash incompatibility that 3DR talked about earlier on.

A certain make of SD, actually painted with PX4 for 3DR. 2GB.

They delayed delivery until they could resolve the issue. My new Pixhawk came, after the delay, with a 4GB Kingston SD, which is supposed to be compatible.

In any case, I understand that later versions of the software should have resolved the timing problem of the original SDs.

So besides that issue, you are seeing a connector problem!?

My SD (on a previous version with the 2GB PX4 SD) failed completely. When I removed it and looked at it on an external drive, it required formatting. Don’t think it was a connector problem… also a bad connector could have resulted in the SD erasing…

Now that I have a 4GB Kingston in the slot, and 3.1.2 firmware, I haven’t had more SD problems… yet.

Maybe someone can confirm, but I don’t think the SD will cause a crash. It’s used for initialization and storing logs. It just won’t boot. Correct me if I’m wrong someone.

Hi Sky,
Thanks for this info. I did not know the initial 3DR PX4 2Gb SD cards were known to be bugged.
I will try with another SD card then.
What is more worrisome is that I already use the latest 3.1.2 and it obviously did not solve the problem of the SD card.
The only way I can boot is to reformat the SD card before each new mission !
This is unacceptable even for a hobby product.
I would hope 3DR would replace the SD card for free.

We did have a batch of bad SD cards from our supplier.
I don’t know how many we shipped before we detected there was a problem. I suspect <20.

In any event if you want a new one just contact help@3dr and they can get one for you.