SD card corruption still with AC3.1.1-rc1

Okay, thought 3.1.1 - rc1 was a fix for the “not wanting to boot - card corruption issue”. I’m still using the stock 2 GB px4 sd card that came with the kit I have. Everything seems to function as expected. System flies good in short hover tests. ( 2-3 minutes) Go back in to fine tune and won’t boot still with 3.1.1 firmware. Have erased and reformatted a couple different ways. FAT32 CORRECT? Under OS X Disk Repair reports directory damage. Not tried under Windows yet to see if any differences there to formatting. Don’t have a better Micro SD ( faster) to try at the moment but will when I can get one. Any suggestions?

at present… could not get back to this until well after dark. A faster Class 10 rated SanDisk MicroSD seems to work now after initializing, spin up, power down in the house. Will test more with bigger actual flight data writes tomorrow in daylight.

A combination of Mission Planner 1.2.93, firmware v 3.1.1-rc1 and a Class 10 micro sd card seems to be working.

For anyone else who has the Pixhawk stock kit 2 gb micro sd card and your phawk will not boot after hooking up to usb. (you get a six tone sequence of three short and three long tones. Is this documented anywhere?) There is another thread here with the same issue but was kind of left hanging for a solution fix. Replace the card with something faster. Class 10 rated speeds have worked for me so far but only tested with SanDisk brand. Thanks to the devs who have worked on this.

Hi pixelDude,

Here you can find the Pixhawk’s list of tones:

If the tone you are hearing is not listed, could you record a video or audio recording, please?

If the card becomes corrupted, you will need to run chkdsk or Disk Utility on it. After that 3.1,1 should not cause corruption. Can you please tell me when your Pixhawk shipped. I am still trying to track down how many vulnerable cards shipped.

[quote=“RogelioN”]Hi pixelDude,

Here you can find the Pixhawk’s list of tones:

If the tone you are hearing is not listed, could you record a video or audio recording, please?[/quote]
Sorry guys, been away for a couple days… hmm thought I was subscribed to this thread to be notified. Anyway, yes it is the “S.O.S.” tone sequence for a missing card. To my ear for what it’s worth, there is not a pause between the tone sequences so it sounds like a 6 tone sequence of three short then three longer tones and then repeats. It is there documented, just was hard to find initially.

I have not run into any real problems thus far. Been away for a few days from testing though. Not directly from 3dr. Shipped out from one of your authorized resellers last day of December. The ones east and south on the other side of video range. ( you might want to contact them ) They did tell me they were missing the ppm encoders they thought they ordered. ( after I reported the one I ordered was missing ) Was delayed in the snow so I got it around the 7-8th if that helps.

I am having the same problem with my micro SD card. I’ve had to reformat it twice. Trying to boot up it plays the SOS buzzer code. I then have to press the reset button, next to the USB port, to get it to boot up with the music. Then it seems to run OK, till the next time, when it all happens again.
When Mavlink is loading the data in, It gets half way then slows right down and loads them by numbers.
I’m running 3.1.1. I wonder if the card holder is damaged in the pixhawk, giving a bad contact.

I’m also waiting for a Kingston 4GB new card to test.

I may be having the same issue I’m not sure. I’ve been having trouble connecting to MP via both the USB and 3DR 915mhz radio using 3.1.1. I’ve spent around 5-6 hours over the past couple of days trying to figure out whats wrong. Sometimes it will connect sometimes it won’t. I’ve never been able to have it keep connection long enough to perform the calibration steps.

I just finished reformatting the flash card and plugged it back in and I was able to connect. The board booted and made success beeps. However, if I wait ~30 seconds to a minute, it will disconnect and the red light (middle one on the right) begins to blink red. After it disconnects repeated attempts to connect / disconnect don’t work. If I disconnect USB plug and plug it back in (power cycle the board) I can connect for another 30seconds to a minute or so.

I’m going to try using a different micro SD card and see if it makes any difference.

EDIT: I fixed the issue I was having mentioned above. The original micro SD card works fine with my pixhawk. I received my pixhawk in the mail at the end of January. My issue was that I was using the 5 wire GPS cable instead of the 6 wire one.

The firmware for Pixhawk heli has been updated to V 3.1.1. One of the updates was " PX4 parameters moved from SD card to eeprom " This solved all my pixhawk–SD start up problems.