SC1_EXTRA1 and SC1_RAW_SENS rates

I need to a rate of 50hz of this parameters in order to use with a companion computer. Initially it is possible to put this at 10hz in the param list, but I need a higher rate. How can I do it?
On the other hand, usually, when you change this in the param list at a value of 10 for example, when you re-start the autopilot suddenly change to the default value again… how can I solve this?

Mission planer changes it. So use mavproxy instead, and set streamrate=-1 --streamrate=-1

After that the stream rates will not get changed

or you can change the default stream rates in mission planner

If I change in the mission planner, the new data rates are saved in the autipilot? Because, when I change in the file param list, then when I analyze that messages with ROS, I see that isn´t really the value that I select.

i don’t mean change the plane params I mean in mission planner settings.

Thanks, but what I want is change on board because I need to conenct the autopilot with a companion computer with ROS.

the code uses the defaults set in params un-till something sets it to something else. The proper way to do it would be to ask for the correct stream rate using the companion computer with SET_MESSAGE_INTERVAL mavlink message (it might be doing this in the background anyway). So you can either stop what ever it setting a new stream rate, or get them to all ask for the same.