SBUS channels wrong

I tried searching but can’t find anything to address this issue. I have two receivers that output sbus, one is an orangerx for my DX8 and the other is an R6303SB for my T12FG with TM14 module. Both receivers are sending a signal and I can see the bars move in radio calibration within mission planner. Problem is the wrong bars move as in when I move the elevator stick the yaw bar moves etc. It doesn’t matter which rx/radio combo I try the exact same thing happens. I can use mixes to fix it but then I don’t have enough mixes left for my switch combinations for flight modes etc.

Please help as I really don’t want to use a PWM to PPM converter. I found one other gent on google having this issue but he doesn’t have any solution other than mixing. in the past, I have changed minor things in the code and recompiled but I am afraid to change something so critical and take a chance on hurting someone by creating a bug that won’t show up until the most inopportune time.

OK, I’m a bit embarrassed to say this but since this is the first transmitter I’ve ever owned (over 40 years of RC) that can have the sticks assigned to any output I probably shouldn’t feel too bad. The Futaba T12FG can do this (my Spektrum cannot) and it’s fairly easy. It’s under the “Linkage” menu and “Function” submenu. It takes a bit of guessing to get the correct channel output to match the stick you desire but it is doable. I would advise taking a picture of the original settings so you can get back to your starting setup in case of a mistake. Everything is working perfect now including failsafe. I hope this helps other Futaba users setup SBUS on their Pixhawk. Don’t forget to change the trims to match the stick/channel output, it’s on the same menu and is right next to the stick output.

I was having the same problem - i.e., I have an OrangeRX receiver which has been successfully bound to a Spektrum transmitter and is recognized on the sbus input on a Pixhawk, however the channels are wrong. Am I to understand that there is no way to re-map the channels other than using mixes on the transmitter?

As I am going through the various tutorials, I saw a screenshot that lead me to believe that QGroundControl could re-map the channels (I typically use Mission Planner), but when I get to RC calibration/Advanced, the drop-down menu that allows selection of the receiver is disabled.

Just about all the wiki pages indicate that the OrangeRX is ‘compatible’ but nothing there about the channels being incorrectly assigned; and since I can’t just switch wires, I’m stack. I am surely missing something here so any guidance would be greatly appreciated.

The channels can be mapped using the RCMAP_ parameters in the Full Parameter List in the Configuration Tab.


Thank you - appreciate the quick response; I assume the tab you are talking about is in QGroundControl as I could not find the RCMAP set of parameters in Mission Planner.

So in QGroundControl I have found the RCMAP parameters (RCMAP_ROLL, RCMAP_PITCH, RCMAP_THROTTLE and RCMAP_YAW), and initially they are set to 1, 2, 3, 4 respectively. By looking at the RC Calibration screen I can see from my Mode 2 transmitter, the throttle is affecting the roll, the pitch is affecting the throttle and the roll is affecting the pitch, so to start, I set the RCMAP_ROLL to 3 and RCMAP_THROTTLE to 1, then press ‘Set’ on RCMAP_ROLL and RCMAP_THROTTLE. If I power down and restart, the mappings aren’t there. So I restart everything, do the same and this time hit the button on the lower right: Set (UAS) but then I get an error: “Throttle Stick Trim Position Invalid The throttle stick is not in the min position. Please set it to the minimum value”. The problem is, no matter which way I set the throttle or roll sticks, I keep getting the same message.

What am I doing wrong in this case? I am running QGroundControl v 2.0.1(beta) and the Pixhawk firmware loaded is for a quad - I loaded the latest just two to three days ago.

Ok - Even though I never figured out how to do it in QGroundControl, I did figure out how to set them in Mission Planner.

If I connect to Mission Planner with the USB cable, the window with ‘All’ parameters does not include the RCMAP_xxx ones. However, if I connect through the radio, then all the parameters show up, including RCMAP, and unlike QGroundControl, Mission Planner allows RCMAP to be changed as required. After the change I have to ‘reboot’ the controller and then SBus from the 8 channel OrangeRX receiver works as expected.