Servers by jDrones

Sailboat Support

Don’t let a rig with stays on it discourage you. I have an EC 12 and I can break it down for the car in 2 minutes. It takes maybe five minutes to rig it after getting it out of the car

I know somebody who was in communication with him. I had suggested that linear servos be used for the foiling surfaces. I think that was the route he used

mine has this servo with linear slider arrangement, not how I would have done it but I think with PID control the linearity shouldn’t matter too much

I thought it would draw less power and be an easier load for a linear serve than a servo arm on a rotating one. Just my opinion.

That’s encouraging to hear thanks David

@iampete, the error text sound serious?
Parameters are missing from firmware. You may be running a version of firmware QGC does not work correctly with or your firmware has a bug in it. Missing params: -1:FLTMODE6, -1:FLTMODE5,-1:FLTMODE4,-1:FLTMODE3,-1:FLTMODE2,-1:FLTMODE1

I have tried flashing your last code to another Kakute board but with the same error text when connecting it to QGC.
Then I tried flashing it with the version from July, this one
ArduRover V3.6.0-dev (84ba6e85), KakuteF7 001D0029 32365103 30383430, ChibiOS: d0f13540
Still the same error message.

Maybe there is something fishy with my flightmodes…

I want to have 5 flight modes. But it seems Mission planner always sets 6 flight modes. After radio calibration MP seem to bind 6 flight modes to 6 different ranges of RC5_ pwm values.
In my case where I have 5 different switch modes set on my TX, Mission planner skip from mode 4 directly to mode 6, not passing mode 5.

My PWM values from the tx are

  1. 1120
  2. 1280
  3. 1446
  4. 1608
  5. 1770

Since I want my mode 5 to be RTL and MP skip it, I have put mode 6 to be RTL.
Is there somewhere I can set the ranges or I have to hit within these ranges with setup in the transmitter?

Can this be part of problem?
Stuck here…

nothing to worry about, QGC is not as upto date with the latest firmware as mission planner. I would just do the QGC radio calibration and go back to MP.

The ranges are hard coded in ArduPilot so you have to match them with you transmitter mixer.

1 Like

After using QGC or maybe after updating the MP it seems to be working as it should.
Rudder turns correct direction when unarmed in Manual and Acro and when Armed in manual turns correct. We just disregard what ever direction the rudder turns in Armed and Acro since there is no gps fix. So now I am back to MP.
Just noticed that the Servo2 functionr 124 (wing rudder) is not blank but has a name: RateRoll.
Hoping for weather to test Acro, Auto, Rtl etc on water again.

Some one got that servo function into master before we got the wing sail stuff in. 124 is still correct for your firmware but it will get a new number when it gets in to master.

Okay thanks for letting me know
I was at the lake this afternoon but you cant believe I was stopped from sailing by a pair of black super aggressive swans :angry:
They followed me around and I could not scare them off. Afraid they will snatch my fpv camera with antenna off of the stern of boat.
I met them before but then with my speed boat and then I run them over, but with a slow sailer, I don’t want to risk it.
winter and ice is coming soon :worried:

I have found swans quite relaxed on the water, they get agressive on the shore tho.

ice boat…? :wink:

Haha Yes, maybe cool on the water, but

This pair was following me along when I walk on the ‘beach’ to prevent me from going to the water. I thought I had moved them away down the beach and then disappear to launch the boat - speed boat. But they were very cunning and showed up…

let me get back on the topic of ice sailing boats…

1 Like

yesterday the first snow came and its now around -5 at nights and freeze the lake but melts during days, fear I will not be able to conclude the test of the wing code before winter. Maybe there will some better days when I can go, let’s see.
For the ice and land version of the boat I came to the conclusion to build a frame that can fit on to the boat so there will be no need to build new set up of flight controller servos etc. The frame should ideally have the option to swop between wheels (on land) and skate blades (on ice). I have seen several examples on the net of people doing frames for lasers but they are far from good and there are many hardware issues to solve. It needs to be light, strong and stiff yet bet attachable and detachable in an easy way.
At the moment that project feels a bit daunting :anguished:

Short update on the mini 40 progress, got a Orange Cube (Thanks Hex!) in a waterproof project box. The box is bolted to the existing mounts in the boat, the idea is that you can unscrew the lid to get to the bolts to unscrew the whole box. Hopefully a bit of silicone will make it watertight to the hull. Got a few holes to patch and a few to drill.

2 Likes

Hello everyone!

Did anyone managed to get the wind speed from the anemometer cups using the RPM library?? If so, can you please send the wire connections and parameters??

Thank you!

Welcome, RPM sensors are defiantly working are you on 4.0, this is the wiki RPM instructions https://ardupilot.org/rover/docs/common-rpm.html

and the wind vane https://ardupilot.org/rover/docs/wind-vane-rpm.html

If you look higher in the thread there is some discussion of setup and wireing.

Hi @iampete, thanks for the quick answer!

Sorry, i forgot to give some context. I already followed the discussion and also read both pages but still cant make it work. I noticed that @patmo141 gave up on trying to use this sensor and @karla changed to the NMEA anemometer. Thats why i was looking for specific wiring and parameters from someone that did make it work. And also i want to update the wiki page with more details about the wiring with images and schematics…

I believe my parameter setting for the RPM and WNDV are ok. Im getting a response from rmp1 when connecting/disconnecting the digital pin. But im getting some weird behavior from the rpm1 value, and its probably the wiring.

First, when nothing is connected to pin 54 (im using RPM_PIN 54) rpm1 returns a low value. If i connect just a loose jumper to pin 54 then rpm1 value goes to max and wind_speed also goes to max. Now if i connect this jumper to ground or 5v then rmp1 goes to zero, but wind_speed stays at max value. And lastly if i disconnect the jumper from ground or 5v and touch the jumper contact with my finger the rmp1 value goes up (max+offset) and wind_speed follows. If i release the jumper rmp1 goes to max again and wind_speed follows.

So, by this behavior it seems that wind_speed only follows (is changed by) rpm1 when rmp1 goes above this max value. Im not using the anemometer at this moment, im testing with a simple button, but technically is the same, just a way to open/close a circuit.

Try with RPM_MIN = 0 and RPM_MAX = 0. This should disable any Range checking. You should then see the RPM reported back as RPM1 over mavlink

Hey David,

I had it working with a dry run, set up with aligator clips and some very crude “twists” and then when I soldered it together it was not working. I’m sure I overlooked something. I just ran out of energy/time.

Regarding your test. The ADC on that pin is looking for a rate of opening/closing not just opened/closed. So your test is going to give it really strange results if it gets one spike or one drop. That’s why you are getting weird results when just opening/closing the jumper.

I’ll see if I can dig up the settings/wiring I had. A 10k ohm pull down resistor did do the trick when it was working. If you PM me an address I can mail you a few since I had to order a whole assortment from amazon :slight_smile:

2 Likes

Hey guys, thanks for the support!

I managed to make it work, finally :smile:. You are correct @patmo141, the value of rmp1 only made sense when i connected the anemometer…

The wiring is as follows:

the 5v and ground can be from any source (but both from the same source). it could be from the aux trails, if you connect an esc and battery or you can take directly from the pixhawk.

as for the parameters, it wasnt working because RPM_MIN and RPM_MIN_QUAL were too high for our application, so it would only work for high wind speeds

The parameters are:

BRD_PWM_COUNT,4

RELAY_PIN,-1
RELAY_PIN2,-1
RELAY_PIN3,-1
RELAY_PIN4,-1
RELAY_PIN5,-1
RELAY_PIN6,-1

WNDVN_SPEED_FILT,0.5
WNDVN_SPEED_MIN,0
WNDVN_SPEED_OFS,1.346
WNDVN_SPEED_PIN,14
WNDVN_SPEED_TYPE,3
WNDVN_TYPE,3

RPM_MAX,10000
RPM_MIN,0
RPM_MIN_QUAL,0.1
RPM_PIN,54
RPM_SCALING,0.011119
RPM_TYPE,2

again, many thanks for the support!

1 Like
Servers by jDrones