RTL Issue/Question

I have had a good flight today but it ended with a very strange behaviour.

I started in MANUAL mode, switched between different modes (STABALIZE, FBWA, ect.) and at some point of time, I switched to RTL.

The plane did a nice curve and started to cyrvle around the starting position. I did not do anything but I registered after one round that the plain lost height more and more. The plane got closer and closer to the ground and I tried to get back the control of the plane.

But I couldn’t. The plane landed by himself smoothly circling around.
Good Luck was that nothing happended and the landing was close to perfect, but I am a bit nervous why this happend.

Analysing the data you can see that the plane switched to RTL and circled around perfectly. Than the plane started to descend (why?) and landed. I can also see that the mode changed closely before landing. This was because I tried to switch to MANUAL mode, but even in this mode I did not hat a chance to increase throttle (why?)

Dose anybody has an idea?

I atteched the logs.[attachment=0]flight 20150418.zip[/attachment]


I did some more analysis and figured out that I did switch to Manual mode. But could not increase throttle.
Can it be that I ran out of power? And therefore the throttle did not increase anymore.


[ul]If I look at the Battery Output it looks like I started with not completely charge batteries.[/ul]
[ul]At the point of the max Height the Current drops continously[/ul]
[ul]Throttle Signal still seams to be hight but due to the fact that current is low engine did not run anymore[/ul]
[ul]After switching to MANUAL I see that I tried to increase the throttle, Signal for Throttle goes to the maximum, but Current keeps down[/ul]

All this findings support my idea that I ran out of batterie and due to that fact the engine sopped working.
I do not have any FAILSAFE installed on the arduplane. I have a FAILSAFE in the reveiver programmed wich switches to RTL in case of lost of connection. This was definately not the case here.

I appreciate any help/idea


Yup, you started with a battery at less than storage voltage (assuming 3s) at 3.6v per cell. By 5 minutes your battery was toast and the inevitable happened, gravity won.

Looking at the end voltage that battery is only good for scrapping now as it went to 2.6v per cell :frowning:

I’ve had it happen to myself twice thanks to a couple of faulty batteries, after a couple of minutes flying the plane just slowly descended to the deck. That is one of the nice things with APM, it maintained it’s attitude right down to the deck with no damage sustained.