RTL does not land, but loiters

I had my heli doing a perfect RTL. Then I upgraded to 3.4.6 and it now moves to a point in the sky exactly at the home position but will not land - it just loiters.

Here is a log: 2017-05-21 14-48-23.bin (2.9 MB)

Here is the parameter file: Parameters as at 20 May 2017.param (11.0 KB)

Any ideas?

In the MP line of the RTL command, set height = 0 (zero) Than the copter will land as desired

Was it an auto - mission ?

Should have been in different thread

Actually RTL is broken in Trad Heli in 3.4. All my heli’s flying 3.4 do the same thing. I’m not sure if it’s fixed in 3.5 or not. Never tested it there.

Here is a video of the issue. Sorry, I covered up the mic hole on the phone accidentally when I was reading off the RTL settings. But RTL_FINAL is set to zero, and RTL loiter time is set to 1 second, in this test. Although I guess it works fine in the sim. But it don’t work in the real world yet, for me, with any of my helicopters flying 3.4.6.


Adding the log file from my flight

Hi guys, first attempt at RTL on 3.4.6 today… worked a treat…

bob, when you get a chance could you post your param file so I can see what settings you have that I have missed to get this to work? It works fine for my multi. Does not work with the helis here.

bob end of day 1 on 3.4.6 i think Pitch VFF needs increasing but other than that all OK.param (10.9 KB)

Hi chris, I think it’s the same one I sent you to look at, I spent the whole day yesterday tuning it, and no matter what I did, I just seemed to make things worse, so I ended up in such an unknown state, I reverted to the Param I started the day with, and then tried a RTL at the end of the day…

OK, Rob told me what the issue is with this. If the aircraft has a yaw error it won’t land in RTL. Helicopters yaw to the takeoff heading during the loiter stage of RTL and if it doesn’t hit within 2 degrees of desired heading it refuses to proceed to the next stage (Land).

My hellicopter had up to 8 degrees of steady state yaw error, consistently 8 degress less than target (desired), which I fixed by setting H_COLYAW to 5. RTL now works as expected.

Thanks for your posts. I’m not sure that H_COLYAW is the right parameter to change. Here is an extract from the manual:

Rob, I’m also surprised that we have only 2 degrees within which the LAND function will trigger. That seems very tight. :sweat:

Also, how do you measure the actual degrees of the heli. In the logs it shows a scaled output and looking at my logs its not that different before the flight from after. Here is the log for a perfect RTL:

2017-05-21 14-19-45.bin (1.7 MB)

Here is the next flight where the LAND did not trigger and I had to land it my self:

2017-05-21 14-29-12.bin (2.0 MB)

I can’t see that the YAW was much different going into AUTO mode and when the RTL and LAND commands should have been executed.

What do you think.

So yesterday I flew six perfect missions all with perfect RTL.

Here are the logs for the first three:

2017-06-10 15-09-07.bin (1.9 MB)
2017-06-10 15-16-55.bin (1.7 MB)
2017-06-10 15-23-24.bin (1.6 MB)

Text book. Right?

And then three more. The log file is too big so here is the ALT profile from the log:

So what changed? I’m not sure other than to say I planned a new mission. I was using a stored mission that had been planned under 3.4.3 and was using it after upgrading to 3.4.6 - perhaps that was the problem?

Hope this helps others with the same problem. Mine now seems to have been solved. Thanks.

Hmm… yeah. I can’t see it either. I was told it has to do with helicopters default with “Return to Armed Yaw” set to on in the yaw controller. This is what makes the helicopter yaw around to the original heading. But during the RTL phase, it’s causing a problem if it doesn’t hit within 2 degrees of the target that it took off from. I need to do some more testing with it myself, because I still haven’t gotten it to work with my 600 flybar. I got it to work with the 500. But I need to play with that H_COLYAW setting in the 600 and see if I can get it to land, although that one doesn’t show any at all steady state yaw error. So it’s a bit confusing yet.

1 Like