RTK Inject Issue

I’ve been having an issue with the RTK Inject feature. It appears that RTK Inject is pulling in my RTCM3 corrections just fine, but I’m not able to keep RTK-Fix on the drone. From what I can tell, the 57600 bps data rate for my telemetry link seems to be too slow. If I use a cell modem / bluetooth corrections link instead, RTK-Fix is solid.

Is there a way to get faster (than 57600 bps) data rates from Mission Planner? I’m using an RFD900x radio, but I can’t seem to get Mission Planner to configure the radios to a faster data rate.

Thanks for any suggestions!

P.S. The Ublox F9P documentation mentions running the corrections link at 460800 bps, so my guess is that 57600 is just way too slow.

What airspeed rate are you using, have you got ECC on and are you using Mavlink as ‘Mavlink’ or ‘Raw’? I don’t think baud rate on the serial is the issue.

I have a 433 radio with 57600 bps working fine with RTK, airspeed as 96k, ECC off and Mavlink as Raw - maybe try the same.

mattcmgb, I’ll see, not sure if ECC is on. Are you running the new F9P (L1/L2/L5 bands, not just L1 like the M8P), and are you providing corrections at 5Hz? Also, the F9P seems to send a lot more satellite corrections than the M8P (for example, I’m often locked on 22-25 vs. 12-15 for the M8P).

I’ll check the Air Speed setting and let you know. I was just upping the baud rate setting.


@dakelly, I’m only running L1 for Emlid M+, corrections provided over RTK injections as follows:

Glonass 0.5Hz
Galileo 0.5Hz

Rover unit (onboard) recording at 5Hz, but that shouldn’t affect RTK from base station - I tend to do PPK for my workflow, but am experimenting with RTK at the moment.

Thx. I could run the L1-only at 57600, but these new F9Ps are pumping lots of data now (multi-bands, more constellations, more sats), so thinking the data rate too slow. But will try your ideas tonight!

mattcmgb, My AirSpeed was set to 64. I’ve been able to bump it up to 250 kbps and Mission Planner still connects. But if I then try to raise the baud setting to anything other than 57 kbps, Mission Planner won’t connect. For RTK-Inject to pass the correction data to the radios, it seems like the connect-to-radio (baud) speed would also need to be bumped up, not just the AirSpeed (radio-to-radio). Also, my ECC box is unchecked. Any suggestions or thoughts? Thanks!

For the Emlid, it’s recommended to choose Raw Data in the Mavlink select field. Have you tried that?

mattcmgb, thx, am trying it now. so my settings on the telem radio are

baud = 57
Air Speed = 250
ECC = disabled
AES = disabled
MavLink = RawData

On the F9P base, I’m sending RTCM3 at 5Hz, L1/2/5, GPS/Gal/Glo/SBAS/Biedou. On the F9P rover I’m running 5Hz, L1/2/5, GPS/Gal/Glo/SBAS/Biedou as well. Seems to have good data link integrity here in my lab right now, will need to see if it holds outside in real conditions. Still bugs me that Mission Planner won’t seem to let me set Baud setting higher, 'cuz to me that seems like a bottleneck for sending the corrections.

I’m interested how you get on. The F9P is of interest to me, would need to have camera event logging for my use.

Roger that. I’ve got an excellent working system using a cell phone modem with bluetooth link for inputting the corrections at about 2Mbps (typical bluetooth datarate), but would prefer to simplify the system and just use the RTK-inject feature if I can get it working. But like I said, I’m thinking the 57600 bps apparent limitation on the Mission Planner baud setting is creating a bottleneck for the F9P multi-band RTK setup.

A better long-term solution will probably be for me to replace the RFD900x telemetry radios with a 2.4Ghz radio set that has higher datarate options, but only if Mission Planner will allow a higher baud rate setting.

So still researching… Any suggestions or discoveries welcome!

I haven’t tried this, but perhaps you also need to adjust the ArduCopter parameters for the serial port you are using for the telem radio such as http://ardupilot.org/copter/docs/parameters.html?highlight=serial#serial1-baud-telem1-baud-rate

Good point! I’ll have to give that a try. I was only changing the COMx setting on the Mission Planner side. I’ll look into it…

A quick update… Decided to give up on trying to get rtk-inject to work with my F9P setup. Have tried multiple settings, but it appears that the link becomes bottlenecked as soon as I enable rtk-inject. For example, I see huge delays in Mission Planner telemetry values being updated on the screen when rtk-inject enabled, so doesn’t give me confidence I can fly safely or with reliable rtk lock.

So for now I’m going to continue to use a separate RF link for sending RTCM3 corrections to the drone F9P, and leave the telemetry link for just telemetry.

Don (@dakelly), what RF link are you using? I have used a LoRa link for the RTCM3 link between C94-M8P boards (after some mods on the board). I have recently received ublox F9P boards but have not even opened the box yet. I noted above that you indicate that the F9P may have more data to pass. I plan to try the LoRa link but am open to anything at this point.

Thanks for any help!