RPLidar A2 not showing data in proximity window

Hello all,

I am working on 360-degree obstacle avoidance in a quadcopter. I connected my lidar to the TELEM1 port of Cube black and followed all the procedures in the actual ardupilot documentation. I am finding trouble in getting the data from RPLidar into the proximity window. I have even tried powering RPLidar first and then Cube and vice versa, still no data. RPLidar’s (Vcc, Motoctrl) is powered with 5V BEC.

These are the parameters i have used to set up the lidar

  • SERIAL1_BAUD = “115”
  • PRX_TYPE = “5”
  • PRX_ORIENT = “0”
  • BRD_SER1_RTSCTS = “0”

even i had this issue,
but couldnt solve it


Same here. RPLidar rotates but no data in proximity viewer. Tried different Baud rates, serial ports still no success.

1 Like

Even i have similar issue, need help.

Issue resolved
I was using RPLiDAR A2M4 which wasn’t supporting the current ardupilot firmware and mission planner. So I upgraded my lidar to RPLiDAR A2M8 and it worked well.

1 Like

Hey I have an A2M8 yet it’s not working. How exactly did you get yours to work?

Any success on this front? I am having the same issue

I had success powering my RPLidar A2M8 from the servo rail fed by the 5v BEC from my ESC, rather that powering through the TELEM1 port. Data is now showing in the Proximity viewer. Seemingly the TELEM1 Port provides enough power to spin the motor but not fire the laser at an appropriate strength

1 Like