Servers by jDrones

RPi3B: link 1 down on MAVLink

Hello Guys,
I’m trying to setup my RPi 3B as Companion Computer for my Pixhawk4.
I followed the ardupilot manual: http://ardupilot.org/dev/docs/raspberry-pi-via-mavlink.html
I’m using the TELEM2 port of the Pixhawk and a USB port on my RPi. Therefor I’ using a USB to UART cable.
I installed the required software (couldnt get python-wxgtk2.8 so i took python-wxgtk3.0).
I set the Pixhawk parameters MAV_1_CONFIG=TELEM2, MAV_1_MODE=Onboard and SER_TEL2_BAUD=921600
When I try to connect to my Pixhawk via mavproxy i dont get a heartbeat, just the error: link 1 down.link1down|690x349
Any ideas what I’m doing wrong?
Thanks in advance
Greets

Hi, i installed Apsync on my rpi 3b and work well.
Cmavnode is configured by default to send telemetry to USB port and UDP protocol. Actually i’m using to send video and data in LTE .I didn’t’ answer your question but i suggest to use it if you don’t solve your problem.
http://ardupilot.org/dev/docs/apsync-intro.html

Thanks, im gonna give that a try.
Just one more quick question.
I cant seem to find the parameters on my Pixhawk.
I could find SERIAL2_BAUS as SER_TEL2_BAUD.
But what are the new names of SERIAL2_PROTOCOL and LOG_BACKEND_TYPE called?
Greets

Sorry probably i didn’t understamd your question. Usually i show the parameter tree and write the name in the filter text box. If you write serial then MP will show only who match filter name , so also protocol .
The same if you write Log

Servers by jDrones