[Rover] Motor problems with HKPilot

Hi :slight_smile:

We’re currently trying to make a RC Car working with a micro HKPilot.

  • The GPS module we have is working (even if it’s not really accurate)

  • The telemetry module is working
    However, we are encountering problems with the motors, both the brushless and the servo.
    We connected the brushless motor to the pwm signal number 1 coming out from the HKPilot. And we did the same for the steering with the output number 2.
    We uploaded a mission with waypoints on the Rover and it has been a real disaster ! :joy:
    The rover was going backward with full speed, it was stopping unexpectedly and was not following any kind of path.

  • The compass and accelero were calibrated

  • The cruise speed was set to 0.3m/s and the base throttle was about 20% (we tried a lot of other values also…)

  • The battery was charged (7.2V 2200mAH)

  • The waypoints were loaded

Any idea how to solve the problem ? Is there a way to try the motors manually, to adjust the speed and make it go forward ? And same for the steering servo ?
We tried using an oscilloscope, but it was working only for one specific duty cycle and it was going way to fast.
We also tried using the Mission planner motors tests, but it couldn’t detect any motor.

Also how the rover is supposed to get its actual speed ? (From the accelerometer/GPS?)

I will try to post some pictures of the rover and all the connections we did as soon as possible.

Thank you in advance for any help :slight_smile:

You only write about auto mode, did you try to drive the rover in manual mode first, then steering mode?
You should stick to that order, because otherwise you have no way to tell if everything is working as expected.
Check if steering and throttle are working correctly in manual, then switch to steering mode, hold the rover in your hands and rotate it around its vertical axis. Observe if the steering wheels are countering the rotation, not steering into the rotation. If it is working as expected start to drive around in steering mode and tune it, because the steering mode algorithms are also used for auto mode. If it is not countering the rotation, reverse the steering channel in missionplanner and in your TX.

Thank you @count74 :slight_smile:

Yeah the problem was that we tried without having any RC controller, we only tried with the telemetry module connected to our computer and with a mission loaded on the HKPilot.

We got one RC controller (from HobbyKing as well) today! :smiley:
So the steering is working. It just needs some tunings because the angles are really low right now.
And we also tried the throttle using the same input, and it is working also !

Now we need to find how to connect everything so we can have the steering + the throttle. And then we’ll do our tunings.

As you said, when everything will be working in manual mode, we’ll try to send our first mission :slight_smile:

Thank you for your help! We’ll get you updated