Servers by jDrones

Rover 4.0 Matek F765, blheli32 ESC

Great news, thanks very much for the follow-up report.

@OldRaven, just to be sure, does this mean that you were able to use DShot 600? or just that you found another way to use these ESCs? I’d really like to know if -rc3 works with DShot 600…

I currently have ESC type set to normal , I can try what happens when I put it to DShot.
I will give it a try for you this weekend.

1 Like

@rmackay9 I changed ESC type to D-Shot 600 today and it works fine with my blheli32 esc’s.

The tracks are off the rover atm. But both motors respond very well… Maybe I’m dreaming but it feels like they run smoother opposed to using Normal.

Might have cheered too early.
Wanted to continue today… now it will not arm.
Even a forced arm does not show any life in the esc.
My fear is that it somehow got incorrect throttle input whille powering up and the esc’s now got wrongly calibrated again.

I somehow cannot get in the blheli suit when arurover is on the matek f765
Whenever I try to connect with blheli it gives a message rebooting fc, then a connection error.

blheli suit works just fine with this exact same setup when I have inav of betaflight on it.

Is there something I need to do in ardupilot to make blheli passtrhough working?

@OldRaven, that sounds a bit like the independent watchdog is rebooting the flight controller which shouldn’t happen. This is a guess of course, if you have a couple of dataflash logs we can probably confirm.

You could also try turning off the watchdog by setting BRD_OPTIONS = 0

Changing BRD_OPTIONS = 0 did not help.

Problem persists.

The ESC’s don’t arm when I power the rover. I get the long beep at the end from the esc’s but I need the short double beep to indicate it is armed.

Still cannot get into BL Heli suite with passthrough. BL Heli tries to reboot the FC to probably trigger the ESC’s so It can read the settings… but fails everytime.

I put INAV back on the matek so I could get back in the ESC’s with BL Heli only to find out it was not able to get the settings anymore. Somehow after a couple of tries I could connect to the ESC’s again only to find out the settings where still as I put them in for the rover and all works fine in the BLHeli editor.
As soon as they get a PWM signal of 1500 they arm.

I will put Rover 4 rc3 on it now and do the same setup steps again and see if i can get it to fail again.

I think it’s an arming thing… whenever I power the rover the output on the ESC’s is not 1500 so they will not arm.
Could it be because I have no GPS attached (still on it’s way)?
I have all checks turned off to see if it at least does anything.

Arming is now set to a switch.

… it’s really all guesswork without a log file…

maybe check that RC1_TRIM = 1500, RC3_TRIM = 1500…

I reinstalled rover 4 rc3 and changed 1 thing at a time just to see where it stops working.

I disabled all the checks for now, and set an arm switch.

Every works, and when I arm and check the motors they also work.
Disconnected from mission planner and powered the rover by battery. The esc’s arm and I’m able to arm the rover and the motors and steering works.

Then went back into mission planner and did some configuring.

When I set motor controll the dshot 600 the esc’s don’t arm anymore. Also not when I powercycle or force arm the rover.
Then set motor control back to normal (pwm) and everything works again.

Could it be that dshot is not working at the moment in rover?
It seems to be the issue for me at the moment.

I’m at least happy I can get it to arm and drive around now so I can continue setting it up.
Just hope to get the gps in the mail soon.

1 Like

@OldRaven,

We think the issue with DShot is that the timing is slightly different depending upon the board. So DShot works fine on Pixhawks but doesn’t on this board it seems. I think we will create a custom Matek F765 binary so you can try various timings and see which works. That will take at least a few days to come up with.

Thanks for the feedback!

can you please tell me which PWM outputs you are using, and also send a log of a failing setup?

I will upgrade to 4.0 stable first and then send you a log.

PWM ouputs used are 1 and 3 at the moment.

I upgraded to 4.0 stable.

For some reason my Voltage and Amp monitoring stopped working after rover 4 rc2 or so.

When I enable battery monitoring I get a message that it is not enabled in the firmware or something.
It did work in previous version… I could set the voltage and amp pin, but those variables seem to be gone and I cannot set them.

Is this correct, or am I missing something?

never mind, I had to refresh parameters. Works now :slight_smile:

Let the testing begin.

Every seems to work fine. GPS and Compass work.
Manual mode driving works.
It returns to home.
And did a couple of waypoint tests.

With the Voltage and Current sensor working I can now see how much Amps the motors pull and start doing some more serious waypoint mission testing.

I love this Matek 765’s setup for a rover… I’ll make some pictures of the test setup. Think someone will like this :slight_smile:

1 Like

I found a weird issue with Kakute F7 board. I could not get BlHeli pass-through to work until: DShot150 is off, (PWM mode is on), everything is disconnected and then power applied with battery first and USB after. Once ESCs are all set, I switch back to DShot and it all works (no pass-through again though).

1 Like

@Anton_Khrapov, great, thanks for the report. Any chance i could get a dataflash log of it working and not working? I will try and reproduce here as well. Thanks again!

Unfortunately… There was no SD card in the AP when the testing was done. I’ll see if I can get repeated tests this week.

1 Like

Here are some pictures.
It’s more a test bed for the matek 765. The plan is to build a bigger agricultural rover to do measurements. But we want to test the mission planner first.

I have to do the steering calibration now. It does rth and waypoints, but I need to tweak the steering settings as it trying way to hard to keep heading constantly overcompensating left, right,left , right.

@Anton_Khrapov I will also try what you did and see if DShot works this way, but think I have tried it in that order already.

2 Likes

Re the weaving left and right, if this is only happening during missions then we’ve seen this before on slow moving vehicles. A good example of this was rctestflight’s boxboat but it’s come up with a very slow moving rover created by my main sponsor (EAMS Robotics) as well.

The solution appears to be to increase NAVL1_PERIOD to 12 or higher and NAVL1_DAMPING parameter from 0.75 to 0.85. I’m not completely sure of this but I think it will help.

@rmackay9 , yes the waeving is only in missions. When driving in manual mode all is fine.
When it approaches the waypoint and is closer to the waypoint it stops doing that… it then seems to home in and slow down pretty good.

I did not do any steering adjustments, it’s all still stock settings.

I will also try to get you a log file finally maybe you can spot something.

Servers by jDrones