RF/Throttle failsafe triggered but the drone RTL instead of Continuing mission

Hi all,

There was something weird on the fly that I can not explain.

I set the Radio throttle failsafe as photo above. As you can see, I was flying in Auto mode, the radio failsafe triggrered and it RTL-ed. However, there are some strange things I need you help to make it clear:

  1. The mission needs to be continued instead of changing mode to RTL - as you can see in the param file
  2. I do not see the throttle (Channel 3) went below 800us as I set in the Param. However I can make sure that at the time it changed mode to RTL, there was the disconnection between drone and GCS. This is because I am using one datalink module for both RC controll signal and telemetry signal.

Log is a large file and it is uploading. I will update if you need it to investigate further.

It probably flew too far that it lose signal from your controller. Just disable that failsafe if you need to. Its a safety issue, generally its always a good practice to make sure the drone is flying within connection to your ground station device or controller. Even more so in a populated area.

Dear @bigboy061293

I think your printscreen is self-explanatory. You set your FS_THR_ENABLE to a value that is deprecated since version 4.0. You should instead set FS_OPTIONS properly in order to achieve the desired behaviour.

If you lost the common link that is transmitting both GCS and RC, it is reasonable that it entered in Failsafe mode. If I am not mistaken, this FS_THR_VALUE was more “useful” for old-fashioned RC receivers that had a FS feature to put a smaller value of PWM when losing the link, but the ardupilot firmware has also other means of detecting the failsafe, like the lack of new inputs at the RC link channel.

In the case it is needed, you shall upload it to some cloud and send the public link here… but anyway I don’t think it is necessary, just made the params modification I told and you should have the expected behaviour.

Let me know if you need further advice.

Hi @BrunoBagarini, thanks for the detailed explaination.
First thing first, FS_OPTIONS was 0 and FS_THR_ENABLE was 2 - Continue mission. However, it invoked RTL mode automatically - I don’t know why.

It seems like the FS_THR_ENABLE will never be triggered because if the common link is lost, Arducopter will realize “No recevier” because the SBUS in (which I used in this system) will be pull to low all the time. This explained why I can not see the channel 3 going below 800 in the log.

This is the log, please check in case you are interested in.

The parameter value you set was deprecated, probably it was treated internaly the same as you set it to 1.

Why? You set FS_THR_ENABLE with a value different from zero, so ardupilot was monitoring it.

Yeah, probably ardupilot triggered the FS based on the lack of packets.