Reversing CH2 causes elevator not work

Sorry if question is repeated, I had search and not found anything fits on my question.

I´m finishing mount APM 2.6 with GPS on a plane, currently using Arduplane 3.2.0 and Mission Planner 2.0.
I did radio calibration and uncheck “reverse” on channel 2 and 4 required to get Pitch forward=low…Pitch back=high Yaw left=low…Yaw right=high Suppose all is working fine.
Next step was check all control surfaces moves as expected, on manual mode all channels works fine, but setting stabilizer mode causes elevator and rudder not work, completely dead. There is no response moving plane or moving stick on radio. Mark on radio calibration reverse on channel 2 causes elevator works again (but reversed, I think I can change RC2_REV and RC4_REV to made work as expected, but why elevator is fully dead if I uncheck reverse on Mission Planner setup?

If the control surfaces are not moving in the correct direction in the Manual Mode, you must use the R/C transmitter channel reversing capability.
Do not check or uncheck the “reverse” box next to any of the channels in the MP Radio Calibration screen to change a control surface direction movement when in the Manual Mode.
The “reverse” boxes are to be used only when in a Mode other than Manual, like the Auto Mode, to change control surface direction.

Dear TCIII, thanks for your response.

But I´m afraid I have not explained correctly. On manual mode works fine, elevator and rudder works fine, moves as expected. But unmark reverse checkbox causes elevator not work on other mode rather than manual, using radio sticks not move elevator neither move plane. Mark again reverse checkbox on radio calibration, elevator works again on stabilize mode (I do test with manual and stabilize modes only) but reversed.
That exactly difference between reverse checkbox and RC2_REV parameter?

Check the RC2_REV, uncheck the box will pass it to 0, but the correct value should be 1 or -1, so you have to change the parameter manually in the full list of parameter