Relay function does not work on AUX1 (GPIO 50) and AUX2 (GPIO 51) on Pixhawk board

The setup is a camera trigger via the relay method.
The firmware is Arducopter latest release (as of today).
The test configuration is the following:
-BRD_PWM_COUNT set to 0 (so all of the 6 AUX outputs can be used as GPIO for relay)
-Camera trigger type set to relay
-Relay 1 set to GPIO 50 (AUX1) - I also tested with Relay 1 set to GPIO 51 (AUX2)
-Camera cable connected to AUX1

Test is using mission planner “Trigger now” function on the world map.

Result : nothing happens.

If i test with Relay 1 set to GPIO 52 (or 53, 54, 55), it works.

So is there a bug in the firmware that does not allow to use the first two AUX ports as relay outputs ?

This works fine for me. CAM_TRIGG_TYPE set to 1?


Trigger from Camera NOW and monitor aux 1 Output with meter.

Hi. Im dealing with this issue. I’m using version 4.3 with cube orange. Trying to get a GPIO setup on aux 5. Set servo5_function to -1. Set up a switch on channel 6. Set rc_option to 66. Set relay_pin 5 to 54. I get 0v on aux.5. Checked all aux channels as well. I have a pwm relay i can use but i would really like to make this work. I read all the posts associated with this problem with no luck. Please help. Thanks.

Aux 5 is Servo13

RC chan 6 will produce a relay(1) output on Aux 5.

Ok I’m more lost then I thought. So if i change servo13_function to -1, this should work?

i didnt see your whole post sorry.

It will work if you change all the parameters I posted if you want to a relay output on Aux 5 from a RC chan 6 switch…

No problem, I was updating it with more concise info.

Ok. I’m so close. i have 3.3 V when i toggle the relay in mission planner but not when i move switch.

I have my radio settings from low 999 to high 1999

On the Mission Planner Status tab (below the HUD) does it show ch6in changing when you flip the switch?

under messages the status is relay low and switched on relay high.

And ch6in? You can also look at the Setup>Mandatory Hardware>Radio Calibration screen for Radio 6. You should perform another Radio Calibration anyway and flip that switch when you do it.

yes in that screen(radio calibration) the channel is changing but not when i go to the output screen.

rc 6 should be setup as a GPIO . Correct?

Earlier under rc 6 it said disabled so i changed it to GPIO

That doesn’t make any sense. GPIO is set on outputs. Post the parameter file here let’s see what you got.

parameter list.param (17.7 KB)

You didn’t set this.

And disable this one (set to -1)

Dave, sorry I ghosted you. I maxed out on the amount of posts i could do in one day i guess. The aux output is working correctly now. Thanks.