Relay camera triggering issue, and a platform selection issue

Hello everyone, after a 5 year hiatus I started using my UAVs again and ran into a couple of issues when upgrading to the latest 4.2.3 firmware, explained below,

Camera triggering issue

I have a couple of Copter 3DR UAVs (X8+ and Iris+), running version 3.4.5 and 4.2.3 respectively, I updated the Iris+ to 4.2.3 from 3.x about a week ago and after that I could never make relay triggering work, even though it works perfectly fine on the X8+ 3.4.5 with similar parameters/setup. I am using a regular USB trigger cable that works perfectly in the X8+, and a CHDK camera.

Here’s the relevant parameters I’ve set on the Iris+ running 4.2.3, the camera cable is connected via AUXOUT5

CAM_RELAY_ON     = 1
CAM_SERVO_OFF    = 1100
CAM_SERVO_ON     = 1700

RELAY_PIN     = 54
RELAY_PIN2    = -1
RELAY_PIN3    = -1
RELAY_PIN4    = -1
RELAY_PIN5    = -1
RELAY_PIN6    = -1

SERVO13_MAX      = 2000
SERVO13_MIN      = 1000

Unfortunately these parameters do not trigger the CHDK camera on the Iris+, and I’ve ran out of parameters to experiment with, am I potentially missing something here? The X8+ running 3.4.5 has almost identical parameters (except for the SERVO(n)_'s which were introduced in 4.x), and it triggers the same camera, with the same cable, perfectly. What else could I try here? I’m kinda out of ideas

Platform selection issue

This is the second issue I had, as I mentioned, these are 2 3DR UAVs that have a pixhawk FC, when I tried upgrading them to the latest version of Copter, I was confused by which platform was the appropriate for this FC, for example, the X8+ (3.4.5) shows the following info,

9/24/2022 12:16:28 PM : PX4v2 003A001D 35345107 34343430
9/24/2022 12:16:28 PM : PX4: de6b667d NuttX: 8c965992
9/24/2022 12:16:28 PM : APM:Copter V3.4.5 (83d39eae)

However, when I try upgrading the firmware in Mission Planner, it’s missing the firmware when I select the PX4v2 option in the platform list, so I’m a bit confused as to what I should select here. What I did was try a few options, and fmuv2/pixhawk1 uploaded correctly, however, I don’t know if these are the correct ones or whether they could be causing an issue like the camera triggering problem that I’ve described above.

firmware list

What would be the correct platform option for this UAV?

I’m hoping it wasn’t a lengthy post, but this is as much as I could compress the information, thanks in advance.

Quick update, I measured the voltage on AUXOUT5 with a multimeter, and I could not get any positive voltage reading on the UAV with the problematic triggering, in the UAV that works, I get a reading of 4.20v

Are there any parameters that control whether any voltage is passed on AUXOUT5?

I think Pixhawk1 is the correct choice, unless you’ve got a pic of the flight controller and we can make a better choice.

Here’s a close up picture of the FC, it has the PX4/3DR logo on the sides of the FC, but aside from that there is no more visible information.

Definitely Pishawk1 firmware is the right choice.

Have you tried SERVO13_FUNCTION = 10
I havent got anything set up to test at the moment.

Just tested SERVO13_FUNCTION = 10, and sadly it did not produce any positive voltage on AUXOUT5, I re-attempted all my testing using the Pixhawk1 platform and still could not get it to output any voltage on AUXOUT5.

I think my only chance now is to dump the firmware of the UAV with the working camera triggering using an FTDI cable, and then use it to downgrade the 4.2.3 firmware to 3.4.5. I’m dumbfounded as to what could be the cause of this issue, the drones were working perfectly before the upgrade.

Is there any chance that some parameter, or firmware config is persisting across firmware installs, which may cause this issue? Is there a specific process to reset a firmware to an initial, default configuration?

edit: did some digging, and loaded a rover fw on the UAV to reset all parameters, it had no effect whatsoever


Platform selection issue
I did some research and found out that my FC’s firmware is Pixhawk1, as xfacta mentioned, but there’s a catch, this board specifically only has 1MB of flashable memory, so I had to choose Pixhawk1-1M as the platform. I was able to find this out by looking at the QGroundControl docs, and also attempted to upgrade the bootloader to resolve the 1M issue, without any luck. But that’s ok.

Camera triggering issue
Turns out I was so rusty I looked over really important and basic details

  1. Initially I was using my multimeter to measure the (+) and (-) pins on AUXOUT5, when I should have been testing the (-) and (s) pins for a voltage spike when triggering the camera
  2. After noticing that triggering does send out a 3.3v spike, I researched a bit again and found out that CHDK needs 5v to trigger
  3. All my testing was done by powering the UAVs using a USB cable on the pixhawk, turns out I needed to connect a real battery to get a 5v spike on AUXOUT5, although, this confusion was mostly caused by the fact another one of my UAVs using the older firmware can trigger 5v just fine when it’s powered by USB. I made the wrong assumption that both UAVs could trigger just fine when using USB power.

So, that’s about it, I’m super rusty so I made really basic mistakes. Thanks to everyone who read and offered some help!