Servers by jDrones

Reboot but safe


(Michael De Leon) #1

Hello, Our PH2.1 with 2 power module rebooted in Mid air during RTL. it was still flying good. Can you please check our Logs.

https://drive.google.com/open?id=1Tof_fdg6AbKMBfiJLcn8-Q4LKQ5lkDLB

Thanks


Rebooting mid-flight
(Hunt0r) #2

I am looking at your logs. This is something I’ve not seen before, maybe someone else can help?

Here is a plot of the altitude during the log (blue line). Also, each pink triangle is 50*MODE, so you can see when mode-changes happened: (0=Manual, 100=Stabilize, 250=FBWA, 500=Auto, 550=RTL). Finally, I have plotted a solid vertical black line every time the board “reset.” Specifically, these are the times that the MSG.Message is the usual start-up message triplet:
ArduPlane V3.8.5 (7dc5e040)
PX4: b535f974 NuttX: 2f230473
PX4v2 00330027 3435510B 38393730

00007_alt_reset

Does anyone understand how this message might be continually written, but to the same log-file?

It looks like it happened 3 times on the ground before you flew, do you know if you intentionally caused those?

In case it’s helpful, here are ALL the messages written during the log. (I see another that looks odd, the GCS MissionPlanner 1.0.0.0 reporting it’s version. Not sure if that’s a relevant clue.)
ArduPlane V3.8.5 (7dc5e040)
PX4: b535f974 NuttX: 2f230473
PX4v2 00330027 3435510B 38393730
New mission
GPS 1: detected as u-blox at 115200 baud
u-blox 1 HW: 00040007 SW: 7.03 (45969)
EKF2 IMU0 Origin set to GPS
EKF2 IMU1 Origin set to GPS
EKF2 IMU0 is using GPS
EKF2 IMU1 is using GPS
Executing command ID #178
Set airspeed 15 m/s
Executing nav command ID #16
Executing nav command ID #16
GCS:Mission Planner 1.0.0.0
GCS:Mission Planner 1.0.0.0
ArduPlane V3.8.5 (7dc5e040)
PX4: b535f974 NuttX: 2f230473
PX4v2 00330027 3435510B 38393730
ArduPlane V3.8.5 (7dc5e040)
PX4: b535f974 NuttX: 2f230473
PX4v2 00330027 3435510B 38393730
ArduPlane V3.8.5 (7dc5e040)
PX4: b535f974 NuttX: 2f230473
PX4v2 00330027 3435510B 38393730
Flight plan received
New mission
EKF2 IMU1 switching to compass 1
EKF2 IMU1 switching to compass 0
EKF2 IMU0 switching to compass 1
EKF2 IMU0 switching to compass 0
EKF2 IMU1 switching to compass 1
EKF2 IMU1 switching to compass 0
EKF2 IMU0 switching to compass 1
EKF2 IMU0 switching to compass 0
Executing nav command ID #16
Reached waypoint #2 dist 43m
Executing command ID #206
Executing nav command ID #16
Reached waypoint #4 dist 54m
Executing command ID #206
Executing nav command ID #16
GCS:Mission Planner 1.0.0.0
GCS:Mission Planner 1.0.0.0
Reached waypoint #6 dist 58m
Executing command ID #206
Executing nav command ID #16
ArduPlane V3.8.5 (7dc5e040)
PX4: b535f974 NuttX: 2f230473
PX4v2 00330027 3435510B 38393730
Reached waypoint #8 dist 58m
Executing command ID #206
Executing nav command ID #16
Reached waypoint #10 dist 55m
Executing command ID #206
Executing nav command ID #16
Reached waypoint #12 dist 52m
Executing command ID #206
Executing nav command ID #16
Reached waypoint #14 dist 58m
Executing command ID #206
Executing nav command ID #16
Reached waypoint #16 dist 58m
Executing command ID #206
Executing nav command ID #16
Reached waypoint #18 dist 47m
Executing command ID #206
Executing nav command ID #16
Reached waypoint #20 dist 58m
Executing command ID #206
Executing nav command ID #16
Reached waypoint #22 dist 11m
Executing command ID #206
Executing nav command ID #16
GCS:Mission Planner 1.0.0.0
GCS:Mission Planner 1.0.0.0
ArduPlane V3.8.5 (7dc5e040)
PX4: b535f974 NuttX: 2f230473
PX4v2 00330027 3435510B 38393730
ArduPlane V3.8.5 (7dc5e040)
PX4: b535f974 NuttX: 2f230473
PX4v2 00330027 3435510B 38393730
ArduPlane V3.8.5 (7dc5e040)
PX4: b535f974 NuttX: 2f230473
PX4v2 00330027 3435510B 38393730
ArduPlane V3.8.5 (7dc5e040)
PX4: b535f974 NuttX: 2f230473
PX4v2 00330027 3435510B 38393730
ArduPlane V3.8.5 (7dc5e040)
PX4: b535f974 NuttX: 2f230473
PX4v2 00330027 3435510B 38393730


(Michael De Leon) #3

Hello, thanks for reading our log. During start i did not make reset even in flight. I saw that message when rtl the system and then got disconected . We got connected and that message pop out. That what gave an idea that the system rebooted.


(Michael De Leon) #4

Also it is weird that we switch to auto at 500 agl , switch it to 700agl. ALT_Hold_rtl was set to 70000cm also.


(Michael De Leon) #5

Can you check the temperature of the fc?


(Hunt0r) #6

Why don’t you give that a try yourself? Some hints:
The IMU, BARO (barometer), and ARSP (airspeed) all have temperature information. The airspeed sensor may be located separately from the IMU and BARO, so I might expect it to disagree significantly… maybe post plots of what you find?


(peterbarker) #7

These are written out any time parameters are fetched.


(peterbarker) #8

What sort of GPS unit are you using?

Which sort of safety switch?